Cannot open folders on WSL2 with Cursor editor.

When I tried to open a folder on WSL2 with the Cursor editor, I got the attached screen copy (attachment 1) error. I believe the direct cause is that the file specified in the URL cannot be found (attachment 2).
The two relevant installed extensions are

  1. Remote Development
  2. Docker
    Has anyone else encountered a similar error?
    Also, please let me know if you have a solution.

Thank you in advance.

Ack, thank you for reporting this!

Some info that would be helpful for debugging:

  • Had you used WSL before this update?
  • Have you gone through a Cursor editor update before and had WSL working both before and after that update?
  • Does using WSL in Cursor on a new distro (e.g. ubuntu 20) work for you right now?

Thank you for the information.

I have installed Cursor on my own computer to check the operation of Cursor.
are installed on my computer to check.

I have not updated the Cursor editor.
I recently installed it for the first time.
I checked the WSL connection again this morning,

On Ubuntu-18.04(Ver1), I was able to open the WSL folder.
On Ubuntu-22.04 (Ver2), the same error (Error 404: Not Found) was encountered.

Same here, after updating today.

Version: 0.14.0
VSCode Version: 1.83.1
Commit: edbb49b5481d7fddb9a1115a33617591f39a6d00
Date: 2023-11-02T20:00:53.580Z
Electron: 25.8.4
ElectronBuildId: undefined
Chromium: 114.0.5735.289
Node.js: 18.15.0
OS: Windows_NT x64 10.0.19045

I was having this issue also. Upgraded to 0.14.0 and ran the fix wsl install command in the command palette seemed to fix it for me. Make sure you restart cursor after running thee command.

Thank you very much for your advice.
We have upgraded the version as you suggested and are now able to connect successfully.

1 Like