Currently default to using "code" in some extensions instead of "cursor"

I am using VS Code extension Gitlens and trying to do interactive rebase with it.

Ideally it should bring up the interactive rebase editing window inside cursor, but it defaults to using “code” in the CLI. Below is what it runs:

/opt/homebrew/bin/git -C "/Users/xxxxxxxxx" -c "core.editor=code --wait --reuse-window" rebase xxxxxxxxxxxxxxxxxxxxxxxxxxx

It would be nice if we can have a way to tell the Gitlens that we are using cursor instead. It should be doable as code-insider, the pre release version of VS Code, does it automatically, just not sure how.

Not sure if you want to override the code command, but we do offer that option if you go to the command palette in cursor and type “install code.” Would that fix this?

Can look into more proper support here in the future.

Oh of course. Overriding the command would easily fix it and I can set it up in CLI myself. But there seems to be a proper way to do it, like the way done by code-insider. I just don’t know how.

We will look into this to see if it is possible to fix

1 Like