Glitching screen display under Wayland


Just switched over to Fedora 39 Workstation on my desktop. Installed cursor 0.24.4 and large portions of the UI start glitching into black rectangles a few times a second. Seems to be very prone whenever a variable name/block of code is “highlighted”/selected automatically from the cursor’s position.

Decided to see if the same behavior occurs in VSCode and it does not have the same problem (v1.85.2)

I’m guessing this is Wayland related, as i did not have this problem on my last linux installation just prior to this.

Logged out and switched over to Xorg, works fine now.

1 Like

This unfortunately makes cursor unusable under Fedora 40 ( and any future KDE 6 distro ) + Nvidia as it’s impossible to use Xorg here.

I suspect this could be fixed by fixing Appimage arguments are not passed through to VSCode binary

Once that is fixed, you should be able to pass --use-gl=desktop to force Xwayland. This fixes my issues on VSCode (but doesn’t work for the cursor appimage)

I was mistaken about the argument passthrough from my last post. It seems like arguments are passed through, but some are being masked(?) which led me astray.

This combination of flags works well on my sway 1.8.1 + nvidia 550 (3090) setup (no glitching + sharp text):

./cursor-0.37.1x86_64.AppImage --disable-gpu --use-gl-desktop --ozone-platform-hint=wayland --enable-features=WaylandWindowDecorations

P.S. I wonder if this is related to explicit sync which AFAIK is supported in nvidia driver 555 and wlroots is working on finishing the implementation. Hard to tell though.

My other machines (intel integrated + AMD dedicated work well)