gpt-4-0613 is being used instead of gpt-4o.


Thank you for providing such a user-friendly application.

I am currently using the cursor through the API, but I’ve noticed that gpt-4-0613 is being used instead of gpt-4o.

I frequently use both the editing and chatting features, and I have encountered the following errors:


  • gpt-4-0613 is being used.
  • When I restricted the API model to only use gpt-4o-2024-05-13, I received the error message shown in the attached photo.


  • gpt-4-0613 is also being used here.
  • Initially, I specified the model as gpt-4o, but after specifying the model as gpt-4o-2024-05-13, it started using gpt-4o as expected.

I noticed this issue when I saw that the API usage costs had nearly quadrupled.

Please address this issue at your earliest convenience.

Thank you,


Can you send a request id of the failing chat? I’ll take a look!


Please confirm.

I see a few gpt-4o requests intermixed with the gpt-4 requests. Are you changing the model on the frontend?

I was experimenting with gpt-4 and gpt-4o. The current setup is that in Cursor, gpt-4o-2024-05-13 is specified, and in the OpenAI API settings, only gpt-4o-2024-05-13 is allowed. This setup resulted in the situation shown in the photo.


Investigating this right now! Also will follow up over email and cover these expenses!

1 Like

Hey mate, we reported this on github (Set model to `GPT-4o` but `GPT-4` is used instead · Issue #1482 · getcursor/cursor · GitHub) on Jan 8th and got no love. No one is watching github? We should use the forum instead? Cheers mate.

1 Like

@rishabhy do you have any updates on this? I’m also being affected. If I block the other models but gpt-4o from the OpenAI token configuration, Cursor doesn’t work anymore.

@truell20 friendly bump. Would love any updates on this issue