Indexing codebase is not working

I’m getting a handshake failed error when I try indexing my codebase

Seems like we’re having issues with codebase indexing again. You’ll see “error: Handshake failed.”. We’ll work on a fix as soon as possible.


Thank you for the quick reply, much appreciated.

Not to be an ass, but almost 2 full days without indexing, and python ecosystem frozen since almost 6 months.
Plus some obscure features like a pyright plugin by anysphere, that now is magicaly disappeared.

Hard to justify a sub renewal

would it be possible to explain how the indexing is functioning when in local mode? I was under the impression that only openai’s API itself would be required to build the index, which part of this requires a “handshake”? (not objecting to how you guys are doing it, just curious)

It’s back up but could be slower than usual right now.

1 Like

Hello! it is not working. It only says “Loading…” any solution?

Does this issue still persist for you? Codebase Indexing should be working right now.

Captura de pantalla 2023-10-26 210050
Yes, it still doesn’t work, this comes up all the time.

Having the “handshake failed” as well.

EDIT: and working again, perhaps some transient problem

The reason could be that you don’t have a folder open, but just a single file. Codebase indexing only starts when you have a folder open.

Hello! no, I do have a folder. I have tried reinstalling but it doesn’t work either. Maybe with an older version it can be fixed?