Issue with ipykernel

It appears that there is a persistent issue with the Jupyter environment that is preventing the installation of the ipykernel package. Unfortunately, without resolving this issue, we won’t be able to execute code in the Jupyter notebook.

I already have installed ipykernel, tried different env and reinstall but nothing did worked.

Hi! We’re currently just choosing an arbitrary kernel for the interpreter mode, but hope to support selecting the right kernel later in case people enjoy using it!

i bumped into same issue.
I tried to configure interpreter in Workspace and User settings.

In the Jupyter Output I see proper interpreter is defined:
4:02:29.487 [info] Process Execution: ~/.venvs/env-dev/bin/python3 -m pip list
But when it tries to use the interpreter notebook it fails:

4:02:49.025 [info] Starting Kernel startUsingPythonInterpreter, .jvsc74a57bd0916dbcbb3f70747c44a77c7bcd40155683ae19c65e1c03b4aa3499c5328201f1./bin/python3./bin/python3.-m#ipykernel_launcher (Python Path: /bin/python3, Unknown, 3.11.2) for '~/.cursor/interpreter-notebooks/2023-12-21T12_15_47.997Z-3af95335-61f1-4a7d-bdbb-cdbebf2c896a.ipynb' (disableUI=false)

14:02:49.076 [warn] Failed to get activated env vars for /bin/python3 in 52ms

14:02:49.106 [info] Process Execution: /bin/python3 -c "import site;print("USER_BASE_VALUE");print(site.USER_BASE);print

The “change kernel” menu won’t let me actually change the kernel.
I get error:
14:13:12.695 [error] Unable to select kernel as the Notebook document could not be identified

Tried to hack the notebook file to define a kernel. Not the easy…

Finally I could find a dirty hack… i rename /bin/python3 to /bin/python3.old

has this been resolved? still see

“name”: “”,
“message”: “”,
“stack”: “Running cells with ‘/nix/store/…-python3-3.10.12/bin/python’ requires the ipykernel package.\nRun the following command to install ‘ipykernel’ into the Python environment. \nCommand: ‘/nix/store/…-python3-3.10.12/bin/python -m pip install ipykernel -U --user --force-reinstall’”