Issue with remote tunnel - version mismatch

Thank you cursor team for making the remote tunnel available! Really appreciate you listening to the voice of customers.

I encountered an issue with this feature. Here is the steps:

  1. I installed remote development extension on cursor
  2. On my remote instance: I ran this code:
  curl -Lk '' --output vscode_cli.tar.gz && tar -xf vscode_cli.tar.gz && ./code tunne
  1. Then I go back to VScode, clicked on remote explorer on the left, and saw the running tunnel.
  2. I tried to connect to it. but an error appeared
    On cursor:
Failed to connect to the remote extension host server (Error: Connection error: Client refused: version mismatch)

On remote instance:

Disposed of connection to running server
warn [rpc.14] error handling call: NoAttachedServerError(NoAttachedServerError)

Software versions

Version: 0.35.0
VSCode Version: 1.89.1
Commit: 5f9353ed8be369c4ac2b4d43596f5ff281746ec0
Date: 2024-06-08T04:53:54.048Z
Electron: 28.2.8
ElectronBuildId: undefined
Chromium: 120.0.6099.291
Node.js: 18.18.2
OS: Darwin arm64 23.5.0

Replicating on VSCode
I replicated the steps above on VSCode v1.89 and 1.90. I did not have such issues.

Any suggestions?

You will want to use this download URL:
Then run ./cursor (rather than ./code)

Then try connecting

1 Like

It worked now. Thanks!!