New model! (gpt-4-turbo-2024-04-09)

You can now try out gpt-4-turbo-2024-04-09 in Cursor! Just head to Settings > Models and toggle it on :slight_smile:

(If you don’t see the model name immediately, restarting the editor should have it show up. Uses of the model will just count as normal gpt-4 requests.)


What are the verdicts? Have you guys had time to do any internal benchmarks?


We just started playing around with it! No verdicts yet on our end.


Please add support for it on Interpreter will tell you if it performs any better as well

1 Like

I’m not seeing this model and “Cursor: attempt update” doesn’t seem to do anything.

Any tips to update or see this new model?

Cursor version:

Version: 0.31.3
VSCode Version: 1.86.2
Commit: fcd6e551d6f014d13071eac9bd4904e7e0346720
Date: 2024-04-02T20:20:11.019Z (1 wk ago)
Electron: 27.2.3
ElectronBuildId: undefined
Chromium: 118.0.5993.159
Node.js: 18.17.1
OS: Darwin arm64 23.4.0

Oh I suppose it’s due to Cursor’s incremental rollouts :frowning: would be nice if the manual update retrieved the latest version no matter what

I cant see it?

The new model doesn’t require an update! Have you tried restarting the editor? You should see it after that

I have tried many times :frowning:
Should I reinstall?

Hmm I will look into it! In the meantime, does it work if you type it in manually?

Typing manually worked, sorry did not see that option.

is not 2024 still says its 2021

Is there a plan to make it default for gpt-4?
It overtook Opus in the Arena Leadeboard:

Also is there a plan to add it to the long-context chat (with our own API key) and Interpreter chats?

Also in new gpt-4 model we cant upload image or files now?

works good, have a better context

cant seem to find this model, or how to manually update cursor to surface it

Just restart Cursor and it will show up the model settings.

Restarting does nothing. Still doesnt show up. On latest build.

Apologies about this – You can also add the name manually if it doesn’t show up.