[SOLVED] Inline generation not working with claude-3-opus or models other than gpt-4

Hey there,

I tried using the mixtral-8x7b-32768 model with groq the other day and found that the inline generation to not work. I chaulked it off as an issue with the model not following cursors instructions and switched back to gpt-4.

I was excited to see the release of the claude-3-opus model today and tried to use that, but also am having the same issue. I can’t find the pre-prompt box anymore in the new version of cursor but I know that it was empty for me before this update.

The inline generation deletes the selection and instead replaces it with text along the lines of “Here is the rewritten selection…”


I have exactly the same problem. Code generation/inline edits with Claude Opus (via API key) don’t work, just produce the output ‘Here is the modified code …’. GPT4 works fine.

Glad I’m not the only one with the issue. Hopefully they will have a fix out soon.

Same, I guess it’s not supported yet.

Does this still happen if you try again? Just made a change on our end.

1 Like

Thank you! It works for claude-3-opus now. It’s slower than gpt-4 though which is odd and may be something to look into.

However, mixtral-8x7b-32768 isn’t working when set up as a custom model using these instruction: Using Groq, Mixtral 8x-7b, and Cursor IDE — A Simple HowTo | by Rick Garcia | Mar, 2024 | Medium

1 Like

Thanks! Works for me, too. Speed is comparable to GPT4 in my case.

This seems to be broken again. I can chat just fine with the various GPTs, but Opus simply doesn’t respond at all.

cc @truell20 :frowning:

If it helps, the “Confirm” button next to where you enter your Anthropic API key also seems to be nonfunctional. (Compared to the OpenAI one where it activates and spins on pressing “Verify”.)

1 Like

I have the same problem. Additonally Opus also doesn’t work for me, using the API key

Wow, good link, TY! Got Llama 3 on groq running with it. Main point is “alternate URL”. A bit hard to find, like always with cursor :wink:

Were you able to get it to work with the inline editing?

Yep. Cmd-K and chat work.

“Apply changes” does not, unfortunately.

Cursor team is slow on this very important feature, unfortunately:

It works for me with OpenAI and Anthropic models, but unfortunately not with LLaMa 3 (which works in the side chat panel with the same prompt)