[Solved] Please add claude-3-opus-200k and gpt-4-turbo-128k (and gpt-4-vision-128k) to Long Context Chat when on our own API key

It’s fantastic that you’ve implemented the long context chat feature! This is a great addition to the platform. To further enhance the user experience, could you please also add support for those Anthropic and OpenAI models? It should be a relatively straightforward change to include claude-3-opus-200k and gpt-4-turbo-128k (and gpt-4-vision-128k) when the “Anthropic API key” or “OpenAI API key” options are toggled.

Edit: it seems to be possible, I’ve just added claude-3-opus-200k to models, and when I’m using my Anthropic API key it lets me submit responses using this model. I’m still testing it to see if it’s actually using Opus.

Thanks Cursor team!

1 Like

Can you please confirm this works?

Two days ago when I tested it, I checked my Claude dashboard and it showed that around 100-150k tokens were used for the Opus model after I ran the long context chat once. Be careful, as such a request costs a few dollars.

1 Like

Do you see opus in the dropdown? I’m only seeing sonnet and haiku

You need to manually create claude-3-opus-200k in Models

1 Like

How do you do that?

Ctrl Shift P → Cursor Settings → Models → Add model

I have tried that but it still does not show up in the long context chat mode. Do we still need the api key?

Yes, the API key for Anthropic should be enabled to use the model. However it shows up for me even when it’s disabled.