SSH not working in latest update

Same, actually

Containers are now supported :slight_smile: please let us know if you have any problems with them cc @amanrs

I just signed up to say this. I will cancel my subs too. this bug is hanging there since the beginning. I was trying to accomodate by switching between vscode and cursor. Such bug being untreated is a clear red flag for me.

see you when you are stable enough to be used for a commercial project

1 Like

Remote-ssh is not working in the latest build. The exact same configuration connects correctly in VSCode.

[Info  - 00:53:22.410] Resolving ssh remote authority 'ssh-remote+spacewalk-instance' (attemp #1)
[Trace  - 00:53:22.441] Identity keys:
/Users/----/.ssh/Spacewalk.pem ssh-rsa SHA256:----
[Info  - 00:53:23.75] Trying no-auth authentication
[Info  - 00:53:23.166] Trying publickey authentication: /Users/----/.ssh/Spacewalk.pem ssh-rsa SHA256:----
[Error  - 00:53:23.362] Error resolving authority
Error: All configured authentication methods failed
	at _e (/Applications/
	at /Applications/
	at authHandler (/Applications/
	at Ee (/Applications/
	at USERAUTH_FAILURE (/Applications/
	at 51 (/Applications/
	at e.exports.q (/Applications/
	at q.decrypt (/Applications/
	at e.exports.F [as _parse] (/Applications/
	at e.exports.parse (/Applications/
	at Socket.<anonymous> (/Applications/
	at Socket.emit (node:events:514:28)
	at Socket.emit (node:domain:489:12)
	at addChunk (node:internal/streams/readable:324:12)
	at readableAddChunk (node:internal/streams/readable:297:9)
	at Socket.push (node:internal/streams/readable:234:10)
	at TCP.onStreamRead (node:internal/stream_base_commons:190:23)

I’m running into the same problem here, except my previous SSH sessions I am able to connect to. Might be something to do with installing cursor-server through SSH that is broken?

[Trace  - 23:06:33.199] Server install command stdout:
Downloading server from ''
Error downloading server from


[Error  - 23:06:33.200] Error resolving authority
Error: Couldn't install vscode server on remote server, install script returned non-zero exit status

EDIT: fixed the problem. My VM wasn’t connected to the internet

Same issues here, Remote SSH is broken on entirely after the update.

I believe it is not broken for almost all our users.

can you report the bug along with your version of cursor, what environment you are ssh’ing into and what env you are ssh’ing from. that would help a lot to reproduce and fix the bug.

I’ve been facing this issue since the last update. The cursor tries to open the remote forever.

1 Like

I am facing the same issue. I am on cursor version 0.32.2, and this is my SSH config:

Host res-1-t4-sgr7
  HostName res-1-t4-sgr7
  IdentityFile /Users/myusername/.ssh/google_compute_engine
  CheckHostIP no
  HashKnownHosts no
  HostKeyAlias compute.5114837884017815529
  IdentitiesOnly yes
  StrictHostKeyChecking yes
  UserKnownHostsFile /Users/myusername/.ssh/google_compute_known_hosts
  ProxyCommand /Users/myusername/.pyenv/versions/3.10.14/bin/python3 -S /Users/myusername/google-cloud-sdk/lib/ compute start-iap-tunnel 'res-1-t4-sgr7' '%p' --listen-on-stdin --project=my-project-name --zone=us-central1-a --verbosity=warning
  ProxyUseFdpass no

I am able to connect in vscode via the Remote plugin by selecting the host res-1-t4-sgr7. I am also able to connect in a bash terminal with:

gcloud compute ssh --zone "us-central1-a" "res-1-t4-sgr7" --tunnel-through-iap --project "my-project-name"

When I try to connect to the host in Cursor, it fails with this output message:

[Info  - 12:45:30.407] Resolving ssh remote authority 'ssh-remote+res-1-t4-sgr7' (attemp #1)
[Trace  - 12:45:30.415] Identity keys:
/Users/myusername/.ssh/google_compute_engine ssh-rsa SHA256:59+Q/qT/XXXXXXXH3FyrfFQa21d+wmPXiQR2KX9qkvkg=
[Trace  - 12:45:30.415] Spawning ProxyCommand: /Users/myusername/.pyenv/versions/3.10.14/bin/python3 -S /Users/myusername/google-cloud-sdk/lib/ compute start-iap-tunnel 'res-1-t4-sgr7' '22' --listen-on-stdin --project=my-project-name --zone=us-central1-a --verbosity=warning
[Error  - 12:45:31.88] Error resolving authority
Error: Premature close
	at new NodeError (node:internal/errors:405:5)
	at Socket.onclose (node:internal/streams/end-of-stream:154:30)
	at Socket.emit (node:events:514:28)
	at Socket.emit (node:domain:489:12)
	at Pipe.<anonymous> (node:net:323:12)

Hi @sualeh @truell20 @Jakob, were you able to reproduce my bug? Let me know if any additional logs or info is needed on my end, thanks!

By the way,

gcloud compute ssh --zone "us-central1-a" "res-1-t4-sgr7" --tunnel-through-iap --project "my-project-name"

resolves to:

/usr/bin/ssh -t -i /Users/myusername/.ssh/google_compute_engine -o CheckHostIP=no -o HashKnownHosts=no -o HostKeyAlias=compute.XXXX229704584823637 -o IdentitiesOnly=yes -o StrictHostKeyChecking=yes -o UserKnownHostsFile=/Users/myusername/.ssh/google_compute_known_hosts -o "ProxyCommand /Users/myusername/.pyenv/versions/3.10.14/bin/python3 -S /Users/myusername/google-cloud-sdk/lib/ compute start-iap-tunnel 'res-1-t4-sgr7' '%p' --listen-on-stdin --project=my-project-name --zone=us-central1-a --verbosity=warning" -o ProxyUseFdpass=no myusername@compute.XXXX229704584823637

when connecting successfully to the instance

Here is how I manage to resolve this issue

This problem is still not fixed.
It seems to me that the IdentityFile directive in the config is not taken into consideration.

Here is the relevant section of my config:

Host ngpsc-deploy
  HostName 10.0.x.x
  User deploy
  IdentityFile /c:/Users/bastien/.ssh/id_rsa_gpsc

And here is the log where you can see that cursor is trying to connect with id_rsa instead of id_rsa_gpsc:

[Info  - 15:19:31.165] Resolving ssh remote authority 'ssh-remote+ngpsc-deploy' (attemp #1)
[Trace  - 15:19:31.186] Identity keys:
C:\Users\bastien\.ssh\id_rsa ssh-rsa SHA256:GXV4hL3KcJ2F1eN9M8D7Q6P5O4R3A2S1 (fake)
[Info  - 15:19:31.313] Trying no-auth authentication
[Info  - 15:19:31.343] Trying publickey authentication: C:\Users\bastien\.ssh\id_rsa ssh-rsa SHA256:GXV4hL3KcJ2F1eN9M8D7Q6P5O4R3A2S1 (fake)
[Error  - 15:19:31.446] Error resolving authority
Error: All configured authentication methods failed
	at _e (c:\Users\bastien\AppData\Local\Programs\cursor\resources\app\extensions\open-remote-ssh\dist\main.js:1:143674)
	at c:\Users\bastien\AppData\Local\Programs\cursor\resources\app\extensions\open-remote-ssh\dist\main.js:1:442574
	at authHandler (c:\Users\bastien\AppData\Local\Programs\cursor\resources\app\extensions\open-remote-ssh\dist\main.js:1:438083)
	at Ee (c:\Users\bastien\AppData\Local\Programs\cursor\resources\app\extensions\open-remote-ssh\dist\main.js:1:146547)
	at Se (c:\Users\bastien\AppData\Local\Programs\cursor\resources\app\extensions\open-remote-ssh\dist\main.js:1:146731)
	at USERAUTH_FAILURE (c:\Users\bastien\AppData\Local\Programs\cursor\resources\app\extensions\open-remote-ssh\dist\main.js:1:135280)
	at 51 (c:\Users\bastien\AppData\Local\Programs\cursor\resources\app\extensions\open-remote-ssh\dist\main.js:1:286815)
	at e.exports.q (c:\Users\bastien\AppData\Local\Programs\cursor\resources\app\extensions\open-remote-ssh\dist\main.js:1:157288)
	at q.decrypt (c:\Users\bastien\AppData\Local\Programs\cursor\resources\app\extensions\open-remote-ssh\dist\main.js:1:250425)
	at e.exports.F [as _parse] (c:\Users\bastien\AppData\Local\Programs\cursor\resources\app\extensions\open-remote-ssh\dist\main.js:1:156812)
	at e.exports.parse (c:\Users\bastien\AppData\Local\Programs\cursor\resources\app\extensions\open-remote-ssh\dist\main.js:1:160615)
	at Socket.<anonymous> (c:\Users\bastien\AppData\Local\Programs\cursor\resources\app\extensions\open-remote-ssh\dist\main.js:1:142414)
	at Socket.emit (node:events:517:28)
	at Socket.emit (node:domain:489:12)
	at addChunk (node:internal/streams/readable:335:12)
	at readableAddChunk (node:internal/streams/readable:308:9)
	at Readable.push (node:internal/streams/readable:245:10)
	at TCP.onStreamRead (node:internal/stream_base_commons:190:23)

And I confirm that adding to the list of authorized_keys allows me to connect which confirms the root cause I mention above.

After the most recent update, I tried sshing into my cloud server, but was getting an error. Through logs, I realized that it couldn’t fetch the new cursor server binary. I tried using wget to fetch it myself, and got a 404, e.g. the server binary doesn’t seem to exist. It’s trying to fetch this (including message):

> 2024-06-06 <the time> ERROR 404: The specified blob does not exist..

Could you try this build:

Well I was prompted to download another update this morning, which was able to successfully connect and download it’s required server binaries. So problem seems resolved.

1 Like

I confirm that in version 0.34.6 there is a problem with the ssh connection.
At first I received update 0.34.6 and a problem appeared, later an automatic rollback came and it worked. Now 0.34.6 came again and the problem appeared again.

Can you screenshot the error?

Made an account just to post about this.

Full error from VSCode:

2024-06-08 15:57:31.245 [info] Extension host with pid 13116 started
2024-06-08 15:57:31.275 [info] ExtensionService#_doActivateExtension vscode.emmet, startup: false, activationEvent: 'onLanguage'
2024-06-08 15:57:31.283 [info] ExtensionService#_doActivateExtension ms-vscode-remote.remote-ssh-edit, startup: false, activationEvent: 'onLanguage:ssh_config'
2024-06-08 15:57:31.305 [info] ExtensionService#_doActivateExtension vscode.git-base, startup: true, activationEvent: '*'
2024-06-08 15:57:31.309 [info] ExtensionService#_doActivateExtension Tailscale.vscode-tailscale, startup: true, activationEvent: '*'
2024-06-08 15:57:31.334 [info] ExtensionService#_doActivateExtension vscode.github, startup: true, activationEvent: '*'
2024-06-08 15:57:31.385 [info] Eager extensions activated
2024-06-08 15:57:31.401 [info] ExtensionService#_doActivateExtension vscode.debug-auto-launch, startup: false, activationEvent: 'onStartupFinished'
2024-06-08 15:57:31.404 [info] ExtensionService#_doActivateExtension vscode.merge-conflict, startup: false, activationEvent: 'onStartupFinished'
2024-06-08 15:57:31.411 [info] ExtensionService#_doActivateExtension ms-vscode-remote.remote-containers, startup: false, activationEvent: 'onStartupFinished'
2024-06-08 15:57:31.484 [info] ExtensionService#_doActivateExtension ms-vscode-remote.remote-wsl, startup: false, activationEvent: 'onStartupFinished'
2024-06-08 15:57:31.493 [info] ExtensionService#_doActivateExtension ms-vscode.sublime-keybindings, startup: false, activationEvent: 'onStartupFinished'
2024-06-08 15:57:34.907 [info] ExtensionService#_doActivateExtension ms-vscode.remote-explorer, startup: false, activationEvent: 'onView:remoteTargets'
2024-06-08 15:57:34.920 [info] ExtensionService#_doActivateExtension ms-vscode-remote.remote-ssh, startup: false, activationEvent: 'onCommand:remote-internal.getActiveSshRemote'
2024-06-08 15:57:34.935 [info] ExtensionService#_doActivateExtension ms-vscode.remote-server, startup: false, activationEvent: 'onCommand:remote-tunnels.internal.isAuthenticated'
2024-06-08 15:57:34.978 [error] Error: Missing value for match criteria $HOME/.ssh/config
	at c:\Users\muell\.vscode\extensions\ms-vscode-remote.remote-ssh-0.110.1\out\extension.js:2:454557
	at m (c:\Users\muell\.vscode\extensions\ms-vscode-remote.remote-ssh-0.110.1\out\extension.js:2:454654)
	at w (c:\Users\muell\.vscode\extensions\ms-vscode-remote.remote-ssh-0.110.1\out\extension.js:2:454763)
	at $ (c:\Users\muell\.vscode\extensions\ms-vscode-remote.remote-ssh-0.110.1\out\extension.js:2:603442)
	at async P (c:\Users\muell\.vscode\extensions\ms-vscode-remote.remote-ssh-0.110.1\out\extension.js:2:602275)
	at async g.getConfiguredHostnames (c:\Users\muell\.vscode\extensions\ms-vscode-remote.remote-ssh-0.110.1\out\extension.js:2:470189)
	at async h (c:\Users\muell\AppData\Local\Programs\Microsoft VS Code\resources\app\out\vs\workbench\api\node\extensionHostProcess.js:153:200468) remote-internal.getConfiguredHostnames {"value":"ms-vscode-remote.remote-ssh","_lower":"ms-vscode-remote.remote-ssh"}
2024-06-08 15:57:34.992 [info] ExtensionService#_doActivateExtension, startup: false, activationEvent: 'onAuthenticationRequest:microsoft'
2024-06-08 15:57:35.002 [info] ExtensionService#_doActivateExtension vscode.github-authentication, startup: false, activationEvent: 'onAuthenticationRequest:github'

The direct and only solution to this is to install Remote - SSH v0.107.1 until VSCode fixes this (highly unlikely, it’s been a known thing for awhile).

@amanrs I noticed that I cannot install older versions of this package on Cursor. How can we fix this?

(Note: the error was the same for cursor, I just now noticed I copied the raw vscode one)

Try uninstalling remote ssh, installing this:

Then dragging it into the cursor extensions pane

Also, could you point me to where this error is documented for vscode (i.e a github issues URL)?

1 Like