Ssh not working with cursor

I have been using vscode remote ssh. Shifted to using cursor a few days ago but unable to get it to connect to remote host. We use ECDSA-CERT for authentication. Logs -
[Info - 06:20:04.426] Trying no-auth authentication
[Info - 06:20:04.689] Trying publickey authentication: .ssh/id_ed25519 ssh-ed25519
[Error - 06:20:05.204] Error resolving authority

1 Like

Same here, same issue it is not just you.

Remote SSH is broken entirely in rendering it useless for the time being.

I believe it is not broken for almost all our users.

can you report the bug along with your version of cursor, what environment you are ssh’ing into and what env you are ssh’ing from. that would help a lot to reproduce and fix the bug.

Version: 0.31.3
VSCode Version: 1.86.2
Commit: fcd6e551d6f014d13071eac9bd4904e7e0346720
Date: 2024-04-02T20:20:11.019Z (2 wks ago)
Electron: 27.2.3
ElectronBuildId: undefined
Chromium: 118.0.5993.159
Node.js: 18.17.1
OS: Darwin x64 23.1.0

SSHing from my Macbook Pro (Sonoma 14.1 (23B74))
SSHing into Ubuntu 20.04.6 LTS

Version: 0.32.2
Commit: f8ed437267c50dbc975beb3d51f89c800277bb30
Pro account.

ssh from MacBook Pro M1:

  • OS: Darwin 21.4.0
  • Architecture: arm64

ssh to Linux machine:

  • OS: Ubuntu 20.04.6 LTS
  • Kernel: 5.4.0-176-generic
  • Architecture: x86_64

This fixed itself days later without any action from my side.

So, I manage to fix it by connecting to VM (not via cursor) and removing dir called .cursor_server (or something like that) on that VM. After that I was able to connect to VM

In other words I removed existing cursor server from VM and let it install new one from the scratch

I can’t say for certain what fixed it, but I was able to fix a broken devcontainer, because I fortunately had a similar working one to compare it to. This is what was different:

  1. connected to docker container (outside vscode) and deleted .cursor_server
  2. Disabled all cursor features in vscode settings
  3. AND these changes in .devcontainer:

diff --git a/.devcontainer/localstack/devcontainer.json b/.devcontainer/localstack/devcontainer.json
index 886575d..ea72f91 100644
--- a/.devcontainer/localstack/devcontainer.json
+++ b/.devcontainer/localstack/devcontainer.json
@@ -14,14 +14,14 @@
         "vim.useSystemClipboard": true,
         "vim.useCtrlKeys": true,
         "vim.hlsearch": true,
-        "keyboard.dispatch": "keyCode",
+        // "keyboard.dispatch": "keyCode",
         "vim.insertModeKeyBindings": [
             "before": ["j", "j"],
             "after": ["<Esc>"]
-        "vim.leader": "<space>",
+        // "vim.leader": "<space>",
         "vim.handleKeys": {
           "<C-a>": false,
           "<C-f>": false
@@ -50,11 +50,11 @@
       "extensions": [
+        "vscodevim.vim",
-        "mtunique.vim-fcitx-remote",
@@ -77,7 +77,8 @@
         "version": "latest",
         "dockerDashComposeVersion": "v2"
-    "": {},
+    "": {}
+    // "": {},

If I narrow the cause further I will update