Version 0.8.2 WSL not working

i updated to version 0.8.2 and got same error as before

[2023-08-24 00:48:52.941] authorityHierarchy: wsl+Ubuntu-18.04
[2023-08-24 00:48:52.941] WSL extension activating for a local WSL instance
[2023-08-24 00:48:53.027] Resolving wsl+Ubuntu-18.04, resolveAttempt: 1
[2023-08-24 00:48:53.027] Run: C:\WINDOWS\System32\wsl.exe --status
[2023-08-24 00:48:53.780] WSL feature installed: true (wsl --status)
[2023-08-24 00:48:53.781] Run: C:\WINDOWS\System32\wsl.exe --list --verbose
[2023-08-24 00:48:54.520] Starting VS Code Server inside WSL (wsl2)
[2023-08-24 00:48:54.520] Extension version: 0.80.2
[2023-08-24 00:48:54.520] Windows build: 22621. Multi distro support: available. WSL path support: enabled
[2023-08-24 00:48:54.520] L10N bundle: undefined
[2023-08-24 00:48:54.520] Scriptless setup: false
[2023-08-24 00:48:54.521] No shell environment set or found for current distro.
[2023-08-24 00:48:54.966] WSL daemon log file:
[2023-08-24 00:48:54.971] Probing if server is already installed: if [ -d ~/.cursor-server/bin/74f6148eb9ea00507ec113ec51c489d6ffb4b771 ]; then printf 'install-found '; fi; if [ -f /etc/alpine-release ]; then printf alpine-; fi; uname -m
[2023-08-24 00:48:54.971] Run: C:\WINDOWS\System32\wsl.exe -d Ubuntu-18.04 -e sh -c if [ -d ~/.cursor-server/bin/74f6148eb9ea00507ec113ec51c489d6ffb4b771 ]; then printf 'install-found '; fi; if [ -f /etc/alpine-release ]; then printf alpine-; fi; uname -m
[2023-08-24 00:49:05.842] Probing result: x86_64
[2023-08-24 00:49:05.842] No server install found in WSL, needs linux-x64
[2023-08-24 00:49:05.842] Getting server from client side
[2023-08-24 00:49:05.847] Server available at
[2023-08-24 00:49:05.848] Run: C:\WINDOWS\System32\wsl.exe -d Ubuntu-18.04 sh -c โ€˜โ€œ$VSCODE_WSL_EXT_LOCATION/scripts/wslServer.shโ€ 74f6148eb9ea00507ec113ec51c489d6ffb4b771 stable codium-server .cursor-server --host= --port=0 --connection-token=740391762-567278829-1007093792-1898196742 --use-host-proxy --without-browser-env-var --disable-websocket-compression --accept-server-license-terms --telemetry-level=allโ€™
[2023-08-24 00:49:07.087] Setting up server environment: Looking for /home/focuser/.cursor-server/server-env-setup. Found, executingโ€ฆ
[2023-08-24 00:49:07.088] /mnt/c/Users/qodud/.cursor/extensions/ms-vscode-remote.remote-wsl-0.80.2/scripts/ 2: /home/focuser/.cursor-server/server-e: not found
[2023-08-24 00:49:07.088] /mnt/c/Users/qodud/.cursor/extensions/ms-vscode-remote.remote-wsl-0.80.2/scripts/ 4: /home/focuser/.cursor-server/server-env-setup: Syntax error: word unexpected (expecting โ€œinโ€)
[2023-08-24 00:49:07.088] For help with startup problems, go to Visual Studio Code Remote Development Troubleshooting Tips and Tricks

Could you try running โ€œfix wslโ€ in the command pallette and trying one more time?

Do any of the fixes in this thread work for you?

hmmโ€ฆ same

2023๋…„ 8์›” 24์ผ (๋ชฉ) ์˜คํ›„ 3:08, Michael Truell via Cursor Community Forum <>๋‹˜์ด ์ž‘์„ฑ:

(Attachment 2023-08-24 17-16-10.mp4 is missing)

Could you confirm whether this test build works or not for wsl:

I installed it and tried it after fixing wsl, but itโ€™s still the same :slight_smile:

2023๋…„ 8์›” 25์ผ (๊ธˆ) ์˜ค์ „ 6:02, Michael Truell via Cursor Community Forum <>๋‹˜์ด ์ž‘์„ฑ:

Yep, thatโ€™s expected now. Could you try the newest version of Cursor? (go back to the version of cursor you downloaded from the website, ctrl + shift + p and "attempt update)

So youโ€™re telling me to go back to version 0.8.2?

But the command doesnโ€™t seem to work.
ctrl + shift + p and โ€œattempt updateโ€
This doesnโ€™t change the version, does it?

Iโ€™ll just download it from the website again.

2023๋…„ 8์›” 25์ผ (๊ธˆ) ์˜ค์ „ 9:33, Michael Truell via Cursor Community Forum <>๋‹˜์ด ์ž‘์„ฑ:

Oh no, 0.8.4 is the latest version, I was mistaken.

2023๋…„ 8์›” 25์ผ (๊ธˆ) ์˜ค์ „ 10:05, ๋ฐฐ์˜์˜ <>๋‹˜์ด ์ž‘์„ฑ:

Does WSL work for you on 0.8.4? If you run โ€œFix WSLโ€?

nope but something different.

Stuck on infinite loading.
should i wait??

2023๋…„ 8์›” 25์ผ (๊ธˆ) ์˜ค์ „ 10:34, Michael Truell via Cursor Community Forum <>๋‹˜์ด ์ž‘์„ฑ:

oh!!! it works! thank you

2023๋…„ 8์›” 25์ผ (๊ธˆ) ์˜ค์ „ 10:45, ๋ฐฐ์˜์˜ <>๋‹˜์ด ์ž‘์„ฑ:

1 Like