@Web seems not to work?

Tried w/o context, etc. It hallucinates different cut off dates, or “no web access”, once looked into @Doc (see screenshot). Latest flutter stable is 3.16.9

Do I do it wrong? Seems not documented yet. Would be an awesome (and important) feature!

Version: 0.24.1
VSCode Version: 1.85.1
Commit: 2b43a99503060cf7809cf79540dbc9119c225aa0
Date: 2024-01-27T03:14:19.834Z
Electron: 25.9.7
ElectronBuildId: undefined
Chromium: 114.0.5735.289
Node.js: 18.15.0
OS: Darwin arm64 22.6.0

Hello! I think your second @Web didn’t go through in the input box? I believe hitting enter after typing @Web is required at the moment to confirm that the @ symbol should be applied.

@npour is looking into the problem with the first @Web.

1 Like

Hi! This should be fixed now.

Let me know if you run into an issue again.

1 Like

Great, very quick!

Is there a way to force an update of stable? It’s so random :wink:

Will you be working with Perplexity AI in the future?

1 Like

Could you give me some more information on the randomness? I can look into it if you give me a screenshot (or even better if you can give me instructions on how to reproduce)

Missunderstanding: It’s random in the sense that I never know, when it happens. E.g. I’m still on 24.1, and cannot test your fix from some days ago. Would appreciat the usual “check for update” button :wink:

Else it’s that small popup lower left corner - works seemless once it’s there.

Nightly may be a bit to experimental for my daily productive use?

Could update to 0.24.3

The flutter question seems somehow hard, perplexity and phind also fail on it :upside_down_face: Cursor gets it every 5th trial, or so.

“What is the latest php version?” gets correct answer. Sorry for the confusion, did not expect this to be a hard question.

Did some more tests - the @web access seems not stable, see screenshot. Tried again in new chat (to delete prompt context), same answer. Internet is available.

Thanks for including the screenshot Leoing!

In the current version, I’ve set it so the followups dig deeper into the context included in the first answer. So in your example, the followup “what is the current flutter version” is being asked from the documents included in your first query.

I’m working on improving this (and making it more general) right now. I’ll give you a ping here once the fix is deployed!


Love the direct “coworking” here!

Not working at all ATM. First reply ist on 0.25.1(?), updated, 2nd reply on 0.25.2, MacOS.

Connection to cursor server seems unreliable, too (slow, retries necessary) in the last days (did only a few requests, tho).