Authorization popup not appearing for 3rd party extension logins

I’m trying to use extensions that require auth. The popup box in cursor where I’m supposed to be pasting this code doesn’t appear in cursor. Had the same issue with docify and appmap extensions.


In cursor it just hangs like this and then errors out. Both extensions work fine in vs code.

Still can’t get it to work

It seems like Docify doesn’t have a setting to paste the sign-in code manually.

This page’s URL has a URL after the beginning part. You can copy everything that comes after that part and URL decode it here (you have to click on “URL Decode” a couple of times). Then you got an URL that begins with cursor://aic.docify... and you can open that URL in the browser to redirect to Cursor. That should usually work, but unfortunately, it doesn’t for me. I’m still not logged in after that. :sob:

I think you should ask the devs of Docify to add a setting to paste in the auth code manually.

That actually worked for me, thanks!

1 Like