Autocomplete suggestions are used for basic text editing, can't type simple words

  1. Open a new file and paste some text in that does not include the word “NEW”
  2. Type the word “NEW” into the first line. Cursor suggests “Network” and “Networking”
  3. Press enter after “NEW”.

Expectation: I have a file that starts with the word NEW and a newline.

Observed behavior: I have a file that starts with the word “Network” and no newline. To start a file with the word “NEW” I have to type “NEW” then escape to dismiss the autocomplete, then press enter.

I can’t figure out how to disable this kind of behavior. I’ve checked settings, I’ve checked Cursor > Settings > Settings, I’ve checked the gear icon for “Cursor Settings” (confusing how many settings areas there are) and I’ve checked the AI Pane > More tab > Show settings.

Anybody know how to make Cursor stop replacing the words I type when I press enter or tab after typing them? I would like to be able to type the word “New” and then press enter and get “New” and a newline.

Version: 0.29.1
VSCode Version: 1.86.2
Commit: a962ca5721e80876320cb6a3a500cbc1cf679150
Date: 2024-03-02T20:35:34.996Z
Electron: 27.2.3
ElectronBuildId: undefined
Chromium: 118.0.5993.159
Node.js: 18.17.1
OS: Darwin arm64 23.2.0

Is this intellisense or grey text? Could you post a screenshot of what you see when you type NEW? I’d expect Copilot++ to just trigger on Tab.

Thanks for asking, I have uploaded a screenshot to the original message above, and your question made me realize that this does not happen on blank files, it happens to a file that is unsaved but already has text in it.