Codebase indexing not working for larger codebase?

I’m trying to index a larger codebase, consisting of maybe a hundred files, some of which have several hundred lines of code, spread over many nested directories. But the codebase indexing progress bar kind of stops at this 0.31% and then tell me it is done. When I then try to do @codebase and go to advanced options, it is letting me know that the codebase has not been indexed.
Is there a way for me to manually index my codebase? Since it seems the Cursor indexing solution has trouble with larger codebases


@fpartous Hey, it happened also for me. did you find any solution for fixing it?

Stuck at 0.25% for me, CPU is not really working hard to indicate it does anything.
Would be nice to index only specific folders, there’s a lot of generated stuff it doesn’t need to know about.

1 Like

Hey @RealityMoez , thanks in advance for any thoughts here.

1 Like

I found a workaround for this, as it happened for me too, and I think it’s a bug.

The workaround is to copy the repo in another place (backup), delete the original repo, move the copied repo into the original place again.

It’s like deleting the old bugged indexing, and making a new one.

1 Like

Just for me.
I have learned to just Turn ON the “Index new folders by default” option, and
not to mess-around and try to index the repo by myself.

1 Like

Thanks for your help! It worked and at least it passed the previous frozen points.

1 Like

There seems to be an issue with remote connections when indexing. The “indexing and retrieval” output window is filled with errors like the following:

[error] EntryNotFound (FileSystemError): Error: ENOENT: no such file or directory, stat '/\home\username\folder1\folder2\file.ext'

Just want to mention that we’re aware of this problem on especially large codebases and are working on a fix.

In the meantime, codebase wide chats should work without indexing; they’ll just be a bit less accurate.


Where is this located ?

You should also see this here:

Manually pause and resume indexing worked for me (WSL on Windows 10). You may have to do this multiple times as indexing could hang repeatedly…

Also, restart Cursor a few times to make sure all of the index is valid.

Just adding that I, too, have trouble with indexing hanging.

Yea, codebase indexing has problems right now. Here’s a more recent thread: Can't index any codebase