Can't index any codebase

cursor stopped to complete the index in all the codebases I use it with.
Even the smaller ones.
I though I was hitting the “slow gpt4 requests” I upgrade to Cursor Pro++ (80€ not exactly cheap)…but still no codebase index.

This happens with both nightly and regular cursor.

Really a good product, but damn every day a little (sometimes bigger) problem.

Hope that u can help me


Is a bug on Cursor’s side right now. We’re on it. Thank you for your report!

Any possible ETA on the fix?

We will give you an update as soon as possible. We’re currently experiencing a server outage. :pensive:

1 Like

our database ran out of space (we need lots of Terrabytes haha.) and I just upscaled it so everything is good to go. sorry for that.

again really sorry for the outage. its very much up and running now

My indexing is still failing - ran cursor update and did a hard reboot - anything else to get it running?
edit: working now, another force quit & reload of cursor fixed it

I still cant index any repo. Can we have an eta?

Yeah indexing is still down for me

Edit: Never mind, restarting the IDE made it start working

Did you already try restarting Cursor one time?

So I did restart and that got the indexing to start on one of my codebases but it got stuck at 14% my other project won’t index at all

Restarted, used nightly and regular, deleted index, tried with at least 5 codebases, restart linux, disabled all plugins, sacrificed a lamb, sent all my happy thoughts to cursor…and cancelled my pro++ sub in a moment of weakness :frowning:

It seems like it starts indexing but then stops at around 9-15%

Edit: Switching over to nightly build fixed it

Thank you for your reports. We’ll have another look at it.

We’re still working on it. We’re VERY sorry for the inconvenience.

Yup same issue here, only difference being, I can’t even access embeddings on nightly

This is a huge feature, I understand outages and bugs but we should have an ETA on when we can expect this to be functioning again.

Apologies about this. Indexing new repos should no longer be spotty by EOD today.


it is almost EOD as per PST, when will it be fixed, i am sorry for asking so many times at various places, but i have a deadline to work towards.

it works now for me, have you tried restarting cursor?

Also incase it doesn’t work, guess you’ll have to go back to the pre-historic age, before AI came for a while.