Command 'remote-wsl.connect' not found

Have been using WSL fine on cursor for a few months. Came back to the machine today and all of the WSL environments were failing, possibly an update?

The WSl extension is still showing up as being installed+enabled within the WSL environment and the main windows environment.

VSCode still works just fine with WSL, I can access the wsl shell from both cursor and vscode as well.

Things I have tried:
Updating cursor to most recent version
Re-installing the wsl extension
Running the ‘fix WSL’ command (seems to have no effect)

The extension files for ms-vscode-remote do exist on 0.81.8, and the entry for it exists in the .cursor/extensions/extensions.json

This happened to me once before and I couldnt resolve so I just didnt use cursor for a few months, Eventually fixed by uninstalling fully including manually deleting hidden cursor cache files then reinstalling a more recent version. (i tried this originally but didnt work until waiting a few months, so possibly update related)

Please let me know if you need more information.

1 Like