Completely reinstall cursor and remove all settings

Hi Guys,

In short:
I want to reinstall cursor and delete all settings, to see if that helps my problem. How can i make sure that all settings from cursor are also deleted if i delete the program. Currently it remembers everything when i reinstall it.

Longer story:
Somehow Cursor has problems with Postman and Azure tools plugin. It was working fine before… but since i logged out of azure tools and postman and trying to login, im keep getting useless messages, while in vscode the plugins just work fine.

Azure tools is keep giving me the following authentication errors. I’m using Azure sign in… which seems to work… but returning to cursor im getting this error

image

For the record… this all works fine on vscode… but cursor seems to have problems.

I think Postman doesn’t work in Cursor currently.

For Azure Tools try using the “Azure: Sign in with Device Code” command instead of the normal “Azure: Sign In” command.

image

HI Jakob,

Didn’t try that before. but unfortunately same error :frowning:

Kind regards,
Wouter

Are you getting this popup?

image

Rather than deleting the program, you might try creating a new profile. Profiles are where VSCode stores all its configuration data, and I assume the same is true of Cursor. Here’s the documentation.

Hi, is there any update to this issue? i’m also facing this, and am getting the ‘timeout authentication provider’ error whenever i try to load resources. it lets me login via the azure account extension, but not through the azure resources extension

I haven’t been able to find a solution so far :frowning:

@benjy I believe that if you log in via the Azure Account extension, you are also logged into the Azure Resources extension.

@wtzr Could you walk me through what happens for you when you run “Azure: Sign in with Device Code” command?

HI Jakob,

Same thing. Everything works as expected. The window pops up with the authentication code. I go to the web interface. I´m signed in on the web and it confirms i can go back. But when i got back im getting that Timed out waiting authentication window again.

I´ve tried most of the sign in options, but all give the same error. Also tried signing out through azure:sign out.

But when i return to cursor/vscode it says

image

1 Like

Yeah this (above) is exactly what i’m getting too, login seems to be successful but then timeout errors whenever i try to access anything azure through cursor

Is there anyway to get this working? Facing the same issue, tried to login in different ways. Using Azure Login, Login with Code, AZD CLI, etc… still get the same error:
Timed out waiting for authentication provider to register