Devcontainer builds failing on local and remote docker hosts

Devcontainer builds are failing due to what looks like an incorrect reference to download VS Code Server. Here is a section of log from an attempt to build a new vanilla devcontainer on a remote machine:

[14181 ms] Start: Downloading VS Code Server
[14183 ms] 769e57fc532d17f247b121cdf4b6c37f1cccb540 linux-x64 stable 
[15150 ms] Failed to download VS Code Server ( HTTP 404 - Not Found
[15151 ms] Retrying to download VS Code Server.

And here is a similar excerpt for a failed attempt to build a vanilla container on using a local Docker host:

[24662 ms] Exit code 1
[24663 ms] Installing VS Code Server for commit 769e57fc532d17f247b121cdf4b6c37f1cccb540
[24665 ms] Start: Run in container: /bin/sh
[24671 ms] Start: Downloading VS Code Server
[24671 ms] 769e57fc532d17f247b121cdf4b6c37f1cccb540 linux-x64 stable 
[25585 ms] Failed to download VS Code Server ( HTTP 404 - Not Found
[25585 ms] Retrying to download VS Code Server.
[25754 ms] Start: Run: docker rm -f 93a5a5b7acf35e74a1e77842c29dc86333bc235e0dbd30b6bef08ed36510c9b8
[25806 ms] Error: Server returned 404
    at g (vscode-file://vscode-app/Applications/
    at (vscode-file://vscode-app/Applications/

I have the same issue. Digged a bit into it, it seems that the Docker extension is using the IDE commit hash to identify which version of vscode server to install on the devcontainer, but because cursor is a fork of vscode, it has its own git tree, thus a different commit hash than vscode.

any ideas how to fix it?

Devcontainers are currently not supported in Cursor. Hopefully soon! In the meantime, in case anyone is interested in building an open-source devcontainer extension, this and this repo may be useful as inspiration

Too bad. That was the end of the trial of cursor - devcontainers is a essential part of our development setup.

I’d be happy to test-drive it again when devcontainers are supported

I have the same issue.
This is close to a blocker issue to me. I can hardly imagine to use 2 IDEs, the value promised by Cursor is to improve DX…

Just created a forum account to say pretty much the same. I was really interested in Cursor and I would happily pay if it supported Devcontainers. That’s because it is my only use of Vs Code and it is increasing by the day. I appreciate it may be a smaller user group, but my Cursor story ended when I realised it did not support Devcontainers. Just saying.

Have you tried the latest version of Cursor (0.26)? Dev containers should be supported — please lmk what error you get so we can debug.

1 Like

Thanks. This is good news I think: there is hope!
I have a .devcontainer folder with my own setup, which I’m unfortunately not able to share. I downloaded Cursor yesterday (though it tells me there is an update when I fired it up just now) .

When I repeat the same steps I follow with vanilla Vs Code, I get an error. Steps:

  • Ssh to remote machine (Ubuntu 20.04.6 LTS, Docker version 25.0.0-beta.1, build 2b521e4)
  • Open the repo folder with .devcontainer folder in it
  • Vs code (Cursor) suggests opening it in Devcontainer, or I invoke the Reopen in devcontainer command
  • Everything works as it should with Vs Code.

With Cursor, my IDE window’s bottom bar says: disconnected from devcontainer and my explorer side bar has the repo folder’s name with an exclamation mark next to it. The error is:

The editor could not be opened due to an unexpected error: Unable to resolve resource vscode-remote://dev-container%2B7b22686f737450617468223a222f746d702f74656d702d637572736f722d7473742f646f746e65742d7265706f2d74656d706c617465222c226c6f63616c446f636b6572223a66616c73652c2273657474696e6773223a7b22686f7374223a227373…02f74656d702d637572736f722d7473742f646f746e65742d7265706f2d74656d706c6174652f2e646576636f6e7461696e65722f646576636f6e7461696e65722e6a736f6e222c22736368656d65223a227673636f64652d66696c65486f7374227d7d@ssh-remote%2<DOMAIN NAME OF MY MACHINE GOES HERE>/workspaces/<REPO FOLDER'S NAME GOES HERE>

The error displayed when I hover over the folder name in the sidebar is slightly more informative, I could not find a way to copy that so I typed it:

Unable to resolve workspace folder (ENOPRO: No file system provider found for resource `<THE ABOVE vscode-remote URL GOES HERE>`)

I can try with a sample devcontainer repo from Microsoft later, but this is currently my situation.

@arvid220u I just tried to use this devcontainer from the templates repo, on another ubuntu jammy workstation I’m using: templates/src/dotnet at main · devcontainers/templates (

The results are the same. I get disconnected from the devcontainer and docker ps on the server confirms that the container does not start. This is the latest version of Cursor, which I’ve just updated minutes ago. This behaviour should be reproducable. Can you or someone else just use that reference repo to open it in a devcontainer? Is it working for anyone?

Yeah this is super disappointing. My company uses devcontainers - I wanted this to be my new IDE so bad. Oh well :sleepy:

Our recent builds, 0.34.0-0.35.0, should have some additional fixes here to support remote dev containers. What error do you see?