Go to declaration doesn't work

I cannot get go to declaration to work. Neither with ctrl + click, option from top menu or key binding:

    "key": "alt+l",
    "command": "editor.action.goToDeclaration"

Please advice how to get it to work

What language are you using?

Python, I’ve found that Pylance doesn’t work with this version of vs code (I use latest build for linux):

Also there seems to be Pyright already installed but can’t get it to work either

Hmm think this is a problem with a new release that we rolled out to a few users. As a temporary fix, you can downgrade here: Can't connect to remote ssh server after recent update - #5 by truell20

it worked, thanks

Installing this precious version worked for me too. It seems like it trying to use some custom default Python server but it’s not working correctly.

1 Like

I’m using latest (33.0), and there’s no Python Language Server available. So frustrating! :frowning:

that is super weird. you shouldnt really see that. but you can also download directly from the marketplace and drag it in.

I just discovered that on an old project, PyLance works like a charm, but not in a fresh new folder with new Python files. At least I found a non-intuitive workaround and it’s now doing what I expect it to do.

Hi all, I’m trying to cmd + click on a method to navigate to its declaration but its not working. Just installed latest Cursor and installed the Python plugin that it recommends right after you open a project.

A bit frustrating as I always use this :confused: