How can i stop "alt" from code suggestions when clicked?

Problem is i click alt + tab to switch windows and then my the IDE makes suggestions and make the changes on my code unknowingly to me. This makes me have a buggy code in my project.

Tried going to the keyboard shortcuts turned off all related alt keybindings yet it won’t stop

That’s probably Copilot++. You can disable it in the bottom bar in VSC or in the Cursor Beta settings. Unfortunately, I don’t think you can change the shortcut for that yet.