SSH jump proxy is not working after the update

It seems that Cursor is now using a built-in ssh connection, and it is not working with jump proxy setting. (ProxyJump option in config)

Please fix the bug. or give us the option to use ‘Remote - SSH’ extention as before.

The built-in SSH extention by Anysphere seems to be the problem. By the way, why is Cursor using this extention?

Where can I download the previous version of Cursor?