Sudden Codebase Indexing issue - Handshake failed

Hello lovely Cursor Community,

I know there are sometimes bugs and Cursor isn’t perfect, but most of the time it functions well. What I’m experiencing right now is that the codebase indexing function suddenly stopped working out of nowhere. Yesterday, I worked on a couple of projects, and it worked perfectly. However, since today, it seems that it doesn’t work anymore. I always receive the message “Handshake failed.”

Is anyone else experiencing the same issue? I’ve read through all the articles from previous users who mentioned this, but it seems like no one has found a solution.

Any help would be appreciated.

2 Likes

Yep dosent work.

2024-05-25 14:32:14.675 [info] Handshake start
2024-05-25 14:32:22.939 [info] Handshake start
2024-05-25 14:32:39.210 [info] Handshake start
2024-05-25 14:33:11.309 [info] Handshake start
2024-05-25 14:34:15.577 [error] Handshake failed:
2024-05-25 14:34:15.577 [error] Error: timeout in handshake with retry
at e.RepoClientMultiplexer.handshakeWithRetry (/Applications/Cursor.app/Contents/Resources/app/extensions/cursor-retrieval/dist/main.js:2:995054)
at async m.getServerStatus (/Applications/Cursor.app/Contents/Resources/app/extensions/cursor-retrieval/dist/main.js:2:1009958)
at async m.startIndexingRepository (/Applications/Cursor.app/Contents/Resources/app/extensions/cursor-retrieval/dist/main.js:2:1012203)
2024-05-25 14:34:15.577 [error] Handshake failed.
2024-05-25 14:34:15.578 [info] Indexing job successfully done or aborted.

I’m having the same issue right now :d

Just confirming the same on a new install of Cursor has the same issue. Upgraded to Pro to save on my own API costs and did not affect the indexing (not that I expected it to).

Small infra issue with indexing at the moment, will have it back in an our or so.

1 Like

Should be fixed! Let us know if you see anything off on your end.

Works now :+1:

Same issue…

same problem