Unable to Copy/Paste and/or type in cursor


I just started using Cursor and I have a problem, I can’t copy/paste. If I restart the app it fix the issue temporary.

The issue happened again, it’s even worst, I can’t type at all. I noticed that it happen in the main window. If I open a New Window, and drag the chat or file there, I can type again.

I was just about to subscribe to the service :S

My system information: Macbook Pro M1

Version: 0.28.1
VSCode Version: 1.86.2
Commit: 1395c0df045dcedf40d58577920b75622ebed030
Date: 2024-02-26T09:10:03.964Z (2 days ago)
Electron: 27.2.3
ElectronBuildId: undefined
Chromium: 118.0.5993.159
Node.js: 18.17.1
OS: Darwin arm64 23.3.0

Let me know if there is anything that you need to troubleshoot this.

Edit: other interesting fact, if I put the Cursor app (main window) in full screen, I can not exit fullscreen mode:

Sorry about this and thank you for reporting! We’re trying to reproduce on our end right now.

Any reproduction steps would be super helpful if you’re able to find them!

I ran out of free request, so I decided to subscribe. I wasn’t able to figure out yet what trigger this issue. As soon as I find out I will report back.

I have the same issue, when I click full screen I can’t get out of it without closing the cursor window completely.

Any debug output I can enable so I capture something when it happens? I’m determined to find out what the issue is.

The full screen issue is unfortunately an Electron bug from the version that VS Code 1.86.2 is based on: [Bug]: Exit Full Screen button is disabled starting from v28.1.2 · Issue #41023 · electron/electron · GitHub.

Once we upgrade to 1.87 (eta ~1 week), this will be fixed. For now, you can use cmd-shift-P > “Toggle full screen”

Try cmd-shift-P > “Set log level” > “Trace”

If you can figure out any reproduction steps, that would be super valuable.

After removing Github Copilot extension I dont have this issue anymore.

Is there a fix already available for this?
I’ve been experiencing this for a couple of weeks now.
Disabling copilot instantly fixed the bug but I still want to use copilot.

I’ve been having this same issues for 2 weeks now :frowning: wen fix? It’s starting to become unusable, and moving to Zed would be a downgrade at this pt.

Sorry about this. If you can figure out any reproduction steps, that would be super useful!

Github Copilot? Or Copilot++? Or something else?

@truell20 It’s related to Github Copilot. I had the same issue (see above) and removing Github Copilot extension fixed the issue.

1 Like

I’m having the same issue. Tried disabling copilot++ and the copilot extension and reloading, but the issue persists. This has been a consistent on and off issue for me. I’m unable to paste code into the CMD+K prompt and the CMD+L chat.

MacOS. Really would like this fixed since it’s also ruining cursor for me

The same issue for me.

Apple M1 Pro
Sonoma 14.4.1
Version: 0.32.8

VSCode Version: 1.86.2
Commit: 798a1e81a56b0d19565b818839aa2c00fb6ea030
Date: 2024-04-28T22:47:57.969Z (4 days ago)
Electron: 27.2.3
ElectronBuildId: undefined
Chromium: 118.0.5993.159
Node.js: 18.17.1
OS: Darwin arm64 23.4.0

Copy/paste stops working even outside of Cursor.

Are there any forecasts for solving this problem?

i have a similar issue with pasting sometimes taking an extremely long time

0.33.1 is out. Maybe try the latest version first.

Edit: somehow the download was telling my that it’s downloading 0.33.1, after installing now it shows as 0.32.8. So it seems like you have the latest.

1 Like

Do you have Github Copilot extension installed?

Yes, I had, but uninstalled and tried without it - and got the same issue.
Btw, I installed the latest 0.33.1 and so far it works. I’ll observe a little bit longe and report here.

I have upgraded to version: 0.33.1 and have been using it for several days.
At the same time, Copilot++ is active.
The problem has not appeared yet, it seems that it has been fixed.