Using my own open api key vs cursor?

I didn’t realize that I was using my own API despite having cursor. I got a huge bill recently from open api and it seems I’ve unknowingly gotten used to cursor so much :D… however when I checked the settings initially it showed me “not using key”.

I added my own API key before I purchased cursor pro. I switched it on and off couple of times and then I saw that subsequent requests were going through cursor fast requests. (8 of 500)

Am I mistaken here? or is there a bug? or did I accidentally turned it on and have been using it since?

We will investigate to see if this is a bug. If so, we’ll definitely refund you for the month of pro that you paid for.

We also plan on showing how much you are paying for the OpenAI API if using your own API key at some point in the future, which should help in debugging when you are using your API key or not.

Will DM you to help resolve!


@amanrs Apparently having the same issue just discovered after a notification from OpenAI saying I had hit my monthly hard limit. :person_facepalming:

Here’s my typical monthly API usage (minus the last day which is when I signed up for Pro):

After signing up for Pro (which I thought would use not use my API key):

I’ve been doing $10-$13 daily. I had my monthly limit at $120. Last months was billed for $40 ish. So immediately noticed it this month.
I removed the api key in open api website just in case.

Deleting keying from OpenAI Manage API Keys page is what I did too. Just bummed the setting didn’t stay toggled off when I disabled it after signing up tho.

Ack apologies about this @itsbrex @jojo. We should change the behavior of the editor to automatically switch off using your key if you sign up for pro.

Just to confirm, did you also toggle off the key in settings? And that setting wasn’t honored? Or did you toggle it off and it toggled back on when you rebooted? Or you never toggled it off. Want to get to the bottom of the bug here.

Also, could you email with the emails you used to pay. No matter what, want to refund you for the confusion here.

For me the toggle stayed off, but was still using the open api key…

Thanks so much! Yes, I definitely toggled it off and it did not stick. Not something I would’ve inadvertently left on. I’ll send you an email. :pray:

Hey was just wondering if this was fixed?

Same here. Before pulling it off, it’d be nice to double check to avoid disaster billing :smiley: