VS Fork question

How diverged is your fork with the original vscode, I am on ubuntu and have tons of issues that I dont have on the standard vscode. Things like debugging and using conda just seems to have endless small bugs that don’t work.

3 Likes

This was the #1 reason I switched back to VSCode and Github Copilot, even though I find copilot to be inferior than Cursor’s autocomplete.

Besides a few major compat issues, I was hitting into dozens of tiny papercuts in my Cursor (but not in VSCode). These started adding up frustratingly, and hurting productivity… I concluded that it’s the most likely divergence from VSCode and the release/extensions trailing behind compared to the Insider build of VSCode causing this.

I wonder if the Cursor team could provide most of its feature set within VS Code itself? That would bring me back to Cursor. Curious to know at this stage, which bits of Cursor actually require maintaining an entire fork of VSCode?

2 Likes

I’m lucky with my environment and extension collection so that there are no critical issues at the moment. I wrote into another thread some speculation that trying to keep up merging back VSCode changes might become very difficult and that all is probably causing hiccups to actual core product development.

I am also on the brink of switching to VSCode myself. Copilot++ is still something that keeps me as a Cursor user. I don’t know if the Cursor team has been talking to VSCode team about extensibility points to support e.g. Copilot++ use case. Continue.dev extension shows that most of similar functionality can exist in an extension.

3 Likes

It would be fantastic if the team can consider making cursor a plugin in VsCode (if that’s even possible). I need tunnel feature that is available in VsCode but not in Cursor. Currently I switch between cursor and VSCode.

3 Likes

I’m currently in a similar situation, I have vscode and cursor open, but I kind of just use cursor as a GPT with better context.

As a user of various AI plugins, and knowing that their capabilities are practically no different from Cursor, GitHub Copilot confirms this as well.
It would be better if the Cursor team reconsidered creating a plugin with the same paid plans, which would relieve them of problems with VSCodium. And they would focus all their efforts on developing their functions rather than fixing issues related to the editor’s functions.

1 Like

Hey - would love to get more details about these issues so we can get them fixed! Definitely want Cursor to work well for everyone. We usually delay the VSCode merge for some time so that their bugs have some time to be found/fixed.

VSCode extensions have very limited control over the UI of the editor unfortunately (our Command-K and Copilot++ features aren’t possible as extensions, same for much of what we want to build in the future!)

4 Likes

Hi! Currently having issues with keybindings–the appimage also has a run script that doesn’t use the environment’s bash (#usr/bin/env bash (i think)), and persistently get node modules not found for the electron keymap when launching the appimage.

also, no wayland support is rather annoying, as vscode seems to work pretty okay with wayland.

finally, if you could say anything about this codebase indexing issue, would be super appreciated. i’m unsure what to do, tried all the channels and haven’t gotten any real responses: Codebase Indexing Issue - #11 by darink

+1

I don’t understand this, continue has a command k like feature : continue/docs/static/img/inline.gif at main · continuedev/continue · GitHub

Could you explain?

Also can we get some idea of the roadmap? There are lots of interesting / enticing developments outside cursor

3 Likes

This is in Jetbrains I believe. They don’t have this in vscode because it is not possible.

not according to the docs:

See the bottom of that image

They show the jetbrains version for a reason. You should try it in vscode, it’s not really the same feature.

They hack around the vscode apis to try to let you do this, but it is much worse.

1 Like

What issues do you have with Cursor that stop you from switching to it?

  1. I had a conda env and when I tried using it from the cursor terminal, I got endless issues and bugs, so I had to bascially use cursor as a GPT and normal vscode as the terminal.

  2. Plugins don’t work / are hard to find and install, for some reason I could not find the default c++ plugins if I searched in the store, I had to cp them over from the normal vscode plugins folder (I’m on Ubuntu). I want some kind of apt install.

  3. I cant go into a terminal and type " $cursor . ", which should open cursor in my current folder.

  4. The indexing doesn’t seem to really work, see this issue: Is cursor even reading the code?

I understand that its not much of help if I dont provide examples or go into more details only saying: it does not work. But thats the reality for me, I don’t have time to debugg this stuff right now, sorry. Also I have recently been using gpt4o from the openai website, and it seems 1000x smarter compared to your built in version, not sure why.

3 Likes

Super curious about gpt-4o feeling smarter on the openai website.

Do you have an example on hand where OpenAI felt better? NW if it’s private, but would be very useful for us.

It’s always constantly in a state of broken. Earlier this week you released, gpt-4o-128k with google flash gemini. Now I can’t even use those models in Cursor anymore. Using cursor feels like we’re always using the nightly build except without proper release notes.

1 Like

Since the update with 128k context the @Linter is also not working anymore its straight up gone and AI Review also blank page. Made Issues on GitHub for this, no clue there even get read tbh

3 Likes

@aiur
We’ve since moved GPT-4-128k and Google Flash Gemini into long context chat only. You’re right, this definitely should have been in the release notes.

I just saw 3 versions over 1-2 days with something broken in each release. c’mon man, y’all just deploying your hourly builds to us

1 Like

You’re definitely right, this was a buggy release. We plan to do much better in the future.