Web search with openrouter models (or custom models)

For some reason, web search does not work with openrouter models, but without search everything works fine.

This is how I define the Base URL:
https://openrouter.ai/api/v1

There is a very long search with openai/gpt-4o and with next result:


As you can see, it’s just empty!

But with the claude-3-opus model it simply gives a connection error.
My request id with claude: be23589e-2d8c-4dc9-86aa-07acd4d85e8d

1 Like

I’m experiencing the same issue

Were you able to solve your problem? According to the deleted reply

There was a problem with the DNS on my local network. Restarting the router and flushing the DNS cache on my Mac solved the issue.

1 Like

Unfortunately, I don’t have custom DNS or network settings at all, I don’t use VPN, etc.
I would be grateful to someone who could tell me how to check which requests are being generated and how to view the detailed error. I tried opening DevTools, but in the Network tab I couldn’t find any requests.

Maybe there are some logs?