Bug in indexing new docs


Newly added documents are not being indexed correctly, causing search-ability issues and returning undefined results. I made a Github issue here.

Detailed Description:

As of today, I’ve noticed that the documents I’ve been adding to the system are not being indexed as expected. This is preventing the documents from being searchable, and in some instances, is causing the search to return ‘undefined’ results. I tried doing this with increase.com and Run Alloy and both have the same issue on not being properly indexed.

Steps to Reproduce:

  1. Open Cursor.
  2. Add a new document.
  3. Observe the status, which shows “Indexing…”
  4. Notice that the document appears to be added but is not properly indexed, affecting searchability.

What Has Been Tried:

  • Logging out and back into the application.
  • Force quitting the application.

Last Known Working State:

The feature was functioning correctly as of yesterday, without any known indexing issues.

Apologies about this. We were having intermittent issues with our servers used for docs indexing.

We provisioned a few more servers and believe this problem should now be fixed. Could you confirm whether things are working on your end?

This issue still persists for some. I have had success with any docs hosted via readthedocs, but not so much with something like: Reflex App .

Tagging @truell20 to look into this

I was able to reproduce this issue on my end @ppate2 and @ady. We have a fix that should be pushed out tomorrow morning. Thank you for reporting it!

Hey, I tried indexing Reflex App today again, it still does not work (both on the regular and the nightly versions).

Could you try now? Just made a change.

I can’t seem to get docs indexing to work, the issue appears as described in original post here.

was it ever fixed? looks like Indexing sometimes not working correctly or docs not appear in the settings (rebooting Cursor helped)

Our traffic on indexing has been absolutely insane! I am looking to make it even more stable this week. ill ping here and check if its not fixed.

1 Like

out of curiosity what is not indexed for you?