Can not prevent CMD+right from triggering accept partial completion

Hi! The feature Accept partial completions with Copilot++ (editor.action.inlineSuggest.acceptNextWord) is always firing with cmd+right on macOS even thought I removed the key shortcut cmd+right from the settings. What is even worse, when I press cmd+alt+right to change the active tab (which I do often), it still executes inlineSuggest.acceptNextWord action, which makes using Cursor very awkward.

Also, rebinding the action to another key shortcut does not work.

Is there a way to disable this feature until the keybindings get fixed?

1 Like

I’m in the same boat. Would love to disable this feature or truly unbind it because I’m often hitting cmd+right just to go to end of a given line. Before I know it, I end up accepting suggested code without intending to.

2 Likes

This bug has me searching for any possible way to roll back to the previous Cursor version. At this point, I’ve found it easier to just enable and disable Copilot when I want a suggestion/autocomplete, but it’s hella annoying because I felt like I was finally reaching an equilibrium with Copilot++ where it nearly effortless to use.

2 Likes

Hey! It’ll be possible to disable this behavior in the next build!

1 Like

Please make it also possible to rebind the action “editor.action.inlineSuggest.acceptNextWord” to another keybinding. Currently it does not work when using vscode’s normal keybindings functionality (from the UI or JSON format). I would like to use acceptNextWork but not with cmd+right.