Chat with codebase results in no context

As you can see in the image it initially uses the codebase context but then afterwards seems to act like I gave it no context. I’m on the latest version of but I have seen this problem on previous versions. I saw a few other bugs that were related to this potentially that were solved but since this is still an issue I’m reporting it. Let me know if you have further questions.

Steps to reproduce:

  1. Download latest version
  2. open any codebase on windows 11 in WSL 2 ubuntu
  3. Open the chat and try to chat with @codebase or alternatively ctrl + enter or alternatively click on the ctrl + enter codebase button

I have tried

  1. Disabled all beta and alpha features
  2. Deleted and resynced the index
  3. Disabled the index from automatically syncing
  4. tried to uninstall and reinstall cursor

System information

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.04.4 LTS
Release: 22.04
Codename: jammy

System Information report written at: 03/09/24 01:53:02
System Name: DEREK-W10PRO
[System Summary]

Item Value
OS Name Microsoft Windows 11 Pro
Version 10.0.22631 Build 22631
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name DEREK-W10PRO
System Manufacturer ASUS
System Model System Product Name
System Type x64-based PC
System SKU SKU
Processor AMD Ryzen 9 5900X 12-Core Processor, 3701 Mhz, 12 Core(s), 24 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 4402, 2023-02-03
SMBIOS Version 3.3
Embedded Controller Version 255.255
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Version Rev X.0x
Platform Role Desktop
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume8
Locale United States
Hardware Abstraction Layer Version = “10.0.22621.2506”
User Name DEREK-W10PRO\Derek
Time Zone Central Standard Time
Installed Physical Memory (RAM) 64.0 GB
Total Physical Memory 63.9 GB
Available Physical Memory 34.9 GB
Total Virtual Memory 70.9 GB
Available Virtual Memory 27.2 GB
Page File Space 7.00 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Running
Virtualization-based security Required Security Properties
Virtualization-based security Available Security Properties Base Virtualization Support, Secure Boot, DMA Protection, UEFI Code Readonly, Mode Based Execution Control
Virtualization-based security Services Configured
Virtualization-based security Services Running Credential Guard
Windows Defender Application Control policy Enforced
Windows Defender Application Control user mode policy Off
Device Encryption Support Elevation Required to View
A hypervisor has been detected. Features required for Hyper-V will not be displayed.

As a follow up you will see that now it says it used no context

(I would have added this to the original post but I can only upload 1 image per reply)

Does this issue also arise if you ask it more specific questions.

For example: “How does the authentication work in the backend?”

It provides a confidently incorrect answer.

For the record I know this works outside of WSL on my machine so this is isolated to WSL. ( I have tried to run fix WSL and I have tried to delete the cursor folder in ~/ for my wsl instance.

Notice that it still has no context but provides some correct info

1 Like

Same issue here. Extremely disrupting.

Want to confirm this as well.
The most I have gotten it to do is to check is the current open file.

1 Like

I also have the same issue. Ubuntu 22.04.3 in WSL on Windows 11.

Version: 0.29.1
VSCode Version: 1.86.2
Commit: a962ca5721e80876320cb6a3a500cbc1cf679150
Date: 2024-03-02T20:35:34.996Z
Electron: 27.2.3
ElectronBuildId: undefined
Chromium: 118.0.5993.159
Node.js: 18.17.1
OS: Windows_NT x64 10.0.22621

I have deleted the index and reindexed, but it’s still not working.

Here’s the continuation of the chat:

None of the response is at all relevant to the actual codebase.

More debugging info. I’ve tried to add the reasoning step, but it still defaults to the global context. Interestingly, in this case, it has injected semantic search for code that isn’t anywhere in the project.

Continuing the output, as I’m limited to only 1 image upload per post as a “new user”.

Chiming in, same issue, also WSL.

same issue here

Same here. As a workaround I tried opening a separate instance of Cursor on the WSL network drive (mounted at Z:\ on my machine). @Codebase works properly there, so I can ask questions and then switch back to the WSL remote Cursor for coding.