Codebase indexed but not being recognized in chat

Hello, I am having trouble using chat with codebase and I’ve tried a variety of things, including ctrl+enter, @codebase. In “Other”, it shows that everything has been indexed. Would appreciate any help


When you click on “Gathering chunks…” or “Reranking chunks…” does it show any files?

No it doesn’t, it’s just empty

1 Like

Just want to add, that I have opened the same folder on my Macbook and underneath global context, it shows all the files are being read. However, on my Windows PC, it’s empty and gives me the response as above. Is this a permissions thing I need to configure to allow Cursor to access my folders? I am using WSL.

I have this same issue as well - also using wsl. no data in gathering chunks or reranking chunks. I tried changing the Index to specifically point to my repo (which Cursor sees) but still empty responses. Codebase Indexing also shows 100% even after “Resync Index”.

1 Like

Update…I went into the “More” settings in the chat and deleted the index (do not Compute Index again). Then I opened a new chat hit @codebase and asked “what does this do?” and I get a response back with basic info on my code.

Even weirder, I went back into More and saw that there was no Index to delete again, so I hit Compute Index and get back 100% sync. Perform the same test and I Cursor does not see my data anymore. I then deleted the index again and re-ran the test and get my repsonse back as expected.

I was under the impression that in order to perform any @codebase functions that there would need to be an iindex available. Maybe I’m misunderstanding what the Index does and happens with/without me pressing Compute Index?

1 Like

Hey, just to update that I have fixed this issue. I assume when you click Resync Index, it auto goes to 100%? This is cause it doesn’t actually read the files. You have to reopen the window in Windows. If you have the VSCode extension WSL, it recommends that you open the code in WSL, but I think that Cursor doesn’t have access to the files if you open it that way - not sure if there’s an alternative fix by modifying permissions somewhere. Hope this helps.

Does anyone solve this issue? I’m facing the same problems using cursor in under the WSL. I never encounter any problems under the windows.

1 Like