Codebase indexing infinity Loading. .

image

image

I entered the OpenAI API key which works fine and I see that the codebase indexing is loading infinitely. Is there any way to check the error log?

Hello, is the problem resolved? I am also experiencing the same error.

I fixed this problem by installing microsoft visual c++ 2015 https://www.microsoft.com/fr-fr/download/details.aspx?id=48145

to debug the codebase indexing, we would like to see the logs, what environment you are on and what version of cursor.

@Atia @zz948003 Do you have a folder opened in Cursor or just a single file?

I opened a Spring project, initially it could index, but after using it for a while, it just keeps loading.
I don’t know how to debug it or troubleshoot the issue. Sometimes it will suddenly recover, but this problem occurs frequently.

Thank you for your reply. I saw your issue on GitHub, but it seems that I cannot solve my problem through trying.

Today I updated the version to 0.32.1, it happened again. And I downgraded the version to 0.31.3, it recovered. My colleague also had the same issue.

sorry this is concerning, I will to reproduce this issue. And fix it, can you send me the logs from Output > Cursor Indexing & Retrieval

Thank you , it seems that upgrading to the new version has solved my problem