Extension Host crashing / CPU @ 500% on 0.12.0

Running 0.12.0 on MacOS 13.5 – everything has been smooth sailing so far but all of a sudden as of 0.12.0 this morning I’m getting two critical faults –

  1. The Extension Host keeps crashing. I’ve tried running Bisect but it’s unable to pinpoint a problem

  2. Cursor is using up 500%+ CPU.

This is the first time I’m having this sort of issue with Cursor in the past few months (overall all has been wonderful). Is there a way I can help pinpoint the issue or rollback to a previous version? I tried looking for links to previous versions and can’t seem to find any, hence my post here.

Many thanks! Happy to provide more info as needed.

So sorry about this!

Could you do cmd-shift-P “Open Logs Folder” and then zip it up and send to hi@cursor.so?

You can use this link for M1/M2 macs to get version 0.11.8: https://download.cursor.sh/builds/2309282nvdy6jey/mac/zip/arm64

And this for x64 macs: https://download.cursor.sh/builds/2309282nvdy6jey/mac/zip/x64

Thanks for the link! Logs sent, and I can confirm reverting to 0.11.8 has resolved the issue (for now). Let me know what you discover! Happy to provide any additional info as-needed.

what this ever solved?
I’m having the same issue.

can you send the logs again to hi@cursor.so as suggested above.