I can't install any extensions via the Extension Marketplace

I can’t search for extensions, it takes too long and times out:

I did a complete reinstall of the application; I did import my extensions from VS Code, and three of them did not work: Copilot Chat, Github Pull Requests, and Jupyter.

It’s due to the VS Code version (I can’t embed another image, but it says it needs version ^1.85).

I’ve been trying to install a version of Jupyter that works, but it doesn’t show up; at one time I was somehow able to get to the extension and when I tried to install, it timed out too.

Please, help! I want to be able to execute the commands the chat is recommending and I can’t without Jupyter.


I noticed I can’t update my settings either… So maybe the imported settings are not fully supported by 1.84, which may be affecting the extensions marketplace too.

Could you open the “network” tab and send the error’d requests you’re seeing?

I am having the same issue. How do I open the network tab?

The request simply times out.


Request Headers:


I get the same 502 error


This issue seems to be resolved today. I am able to access the marketplace

It still isn’t for me :slightly_frowning_face: ; did you change anything?


I didn’t change anything :frowning: it just started working.

@Erid Does the issue still persist for you?

It still persists… However, I just tested with a VPN (USA) and it worked, so my guess is that maybe my country (Costa Rica) is blacklisted from your Marketplace?

@Jakob @truell20 I am encountering this issue now and changing regions via VPN does not appear to resolve the issue. I have also tried various changes to cursor proxy settings to no avail. VSCode works fine currently on my system too (ie. can access extensions). I have also uninstalled / reinstalled Cursor to no avail.

Getting the same 502 error as above:

Sorry to everyone who is affected by this.

We’re working on a fix right now.

1 Like

We have a temporary fix up. Please let us know if you see any issues. Working on a more permanent fix.


Thank you so much for the fast turn-around on this! It is working on my side now.

I have this issue now, has this issue been fixed?

Where is the network tab, how do I open this?

1 Like

“Toggle Developer Tools”

Curious to know if this has been fixed? As I’m about to pull the trigger on a Cursor subscription.