[SOLVED] Autcomplete not working

I’ve just downloaded Cursor, didn’t change any settings. Chat and generate features are working but Autocomplete is not. Please help.

1 Like

+1 Just downloaded and am at the same place in the tutorial. I’m having the same issue, hovering over “Copilot++” in the bottom status bar says “Requires pro (custom model)”. Shouldn’t the auto (default) Copilot++ model be included in the free plan as well, especially in the 14 day pro trial?

2 Likes

Same here. I even upgraded to a paid pro plan, but autocomplete isn’t working. It’s just not suggesting anything. Chat & generate work.

1 Like

Mind sending me an email at hi@cursor.com? I’ll help debug and figure out what’s going on!

@rishabhy Done!

I downloaded today, created an account, went through everything and it showed my account as being on a pro trial (although I believe the copilot++ has some quota even if you are using the free account), but the autocomplete wouldn’t work and I was shown the “Requires pro (custom model)” message.

So I tried logging off/in again to see if maybe it was an account syncronization issue, and same error, closed the app and opened it again, same issue.

Decided to try upgrading to see if that would work, redid all of the previous on/off steps, and it didn’t work. Even the editor shows I am on a pro plan but the error persists:

image

Welp. I started messing with the settings of the copilot++, changed the model from slow to fast, toggled the enable/disable on all of the features and then toggled the copilot++ off/on again and now it works.

This leads me to believe some internal config file had improper defaults on install and all of this toggling around eventually overwrote the broken default setting that was causing this error. Either that or someone from Cursor changed something on their side exactly at the same time I was making those changes.

1 Like

This was the solution. Toggling copilot++ off in the settings and restarting the app.

Fixed! Please let me know if you run into any issues (you may have to reload your editor once).

@tomredman Also, sent you a refund! Should show up in a few days on your end.

1 Like

@truell20 thanks, I also upgraded to a paid plan and it wasn’t working afterwards.

@truell20 could I also get a refund? I would like to evaluate the tool before committing, just paid for the pro because of this issue, and would rather use the 14 pro trial I had.

Done! cc @alexdonaldsonau @average_dev

1 Like

Super thoughtful Michael! I will still likely upgrade again :slight_smile: I think you’re building the future and Cursor’s already been super useful, even without autocomplete.