[SOLVED] </rewritten_file><|eot_id|>

I am getting 1. written into files by Cursor, which breaks the code.
Can anyone at Cursor team fix this please?

@truell20 do you test on Windows machines?

There seem to be several bugs that occur only on Windows.


This is happening to me constantly and I’m on MacOS.

I’m not sure, but it’s only been happening to me since I switched models from GPT-4-Turbo to GPT-4o / GPT-4-Preview.

I haven’t tried switching back yet. It takes a bit of time to delete the end few lines of the file every time I use the Apply feature but it’s not debilitating.

How long has this been happening?

Could you try temporarily turning off privacy mode then pressing apply again. If you share your email I can investigate the logs.

We deployed a possible fix. Let us know if you run into this issue again

Same here.

In addition, a duplicate main function in Python and an extra } appearing at the end of a sentence in TypeScript also happen frequently.

It’s a new token (or similar), I read somewhere.

Just seen it on 33.4

I’d rather keep privacy mode on.

I see @npour updated that you’ve deployed a fix (thanks).
So hopefully that’s fixed it.
If not, I’ll report back here.

I have the same problem after using the Apply button (latest version).

Could you share what the error/output looks like?

Strange, tested Apply 3 times again and does not happen anymore.