The SHIFT for AI notes is not triggered

I am a Chinese, I record the bug as a video.
forgive my poor English, turn on the subtitles for watching.

a bug demo

version: 0.29, OS:Win 11


If you don’t want to watch video, just see it as a summary:

the SHIFT key for ai note is not triggered.
but the SOFT KEYBOARD SHIFT key is working fine.

It’s a strange problem.

1 Like

I’ve asked this question before, and I thought it’s the keyboard problem, but now I don’t feel like it’s a keyboard problem.

Hi! Sorry about this. We had a bug that wouldn’t trigger AI Notes on Windows right now. We have fixed it internally — the next version will contain a fix for it.

all right, tks for your supporting, and forgive my disturbing. :blush: :rofl:

I update to 0.29.1 version.
the AI Notes option is disappeared. :rofl:

Yes, I have the same problem

Same here no AI Notes

1 Like

until version 0.29.1, the problem is existed

The changelog says its now enabled by default so maybe that’s why theres no more option? Regardless, it still doesn’t work same as it hasn’t worked for me since the feature was introduced.

tks, I find that this option is moved to settings

cursor > AI Preveiew enabled

it’s a default option on.



in which release will it be fixed for Windows?
The bug still exists!

Is this still happening for you in 0.29.1?

yes,this bug is still exists. now the soft keyboard can’t trigger it too.
so,if this bug is too difficult to fix, can I change it to another shortcut key? how do it?

hello gay,U can tell me QQ or wechat?

Did you find a solution? it seems that hovering and shift then holding cmd can trigger it after a 2 - 3 sec hold. Sometimes it will show, but usually after a couple of tries, sometimes after a long delay. I am not sure which other commands are overwriting it or if is just really slow.
Also it does not work in notebooks at least on my end. It could be useful but it would need to show instantly.

I’ve sent you my wechat account by message.

tks,but now, soft keyboard doesn’t trigger. I don’t know what happend.

I’m on 0.29.1 on MacOS and this feature works unreliably for me. Sometimes it comes up right away, other times it won’t come up at all.

I think the feature would benefit from an on/off switch; when it does come up, I don’t find the information useful. I’ve looked in Cursor Settings and in the AI sidebar and I don’t see a toggle for it. I’d rather not spend the tokens for it in its current state.

It would be more useful if a) it was reliable, and b) it displayed the signature for the function I’m calling. I want it to remind me what arguments I need to pass in which order. (If anyone knows of a VSCode addon that does that, I’d be grateful!)

You can turn it off by setting cursor.aipreview.enabled to false (go to the vscode settings page and search for it)

1 Like