VSCode Version 1.83 / Cursor

The current VSCode version is 1.83.0 but Cursor has been stuck on 1.80.1 for quite a while.
I think it’s important to keep merging the latest VSCode changes into Cursor and I assume this isn’t too difficult if Cursor is a fork of VSCode. The main issue with this is extension support - I already have 1 extension I can’t use in Cursor because of this.

What’s the current strategy with this and when will the latest VSCode changes be pulled into Cursor?


Which extension are you unable to use?

We were initially merging in VSCode’s changes every two months. When we did the latest merge, it came with a surprising number of bugs, some from conflicts and some from pure VSCode bugs that were introduced in the new version. We were a bit discouraged by this, and decided to try seeing how long we could go without merging, instead just cherry-picking security-related commits.

If there are any extensions that are not possible to use, though, we will definitely reconsider and merge in the latest VSCode release. It’s pretty easy for us to do.

1 Like

I think this is what is meant - PORT - as new function in VScode

1 Like

I can see some people reporting similar issues on Github with other extensions like: Can't upgrade pylance past v2023.6.40 · Issue #973 · getcursor/cursor · GitHub and [Fix Found] Python extension no longer support - Code version too old · Issue #953 · getcursor/cursor · GitHub, and I also had the same issue myself trying to use the Ruby LSP extension and had to switch to VSCode for that cause it shows The language client requires VS Code version ^1.82.0 but received version 1.80.1 on the output console.

I understand the challenge of keeping this in sync, but I think the problem will only grow moving forward.

It start to be a pressing issue. Many of the extensions I use daily are many months old, stripping de facto one of the best feature of vscode, that is the rolling release of new update/features.


1 Like

Github copilot chat is not functioning in the current version

Woke up very excited to try out cursor. upon installation i came across this issue.

My code is critically dependent on the Azure Functions extension, which requires 1.82.0 of vscode, while cursor supports only 1.80.1.

This means cursor was dead on arrival for me, and came with a concern moving forward that i will encounter compatibility problems.

For our team, it’s imperative that Cursor closely follows the release schedule of code, and supports such common extensions.
I’ll have to move back to base vscode and gpt for now.

I dont know if it can be of any help,but if you use the appimage release, you can extract the files within.
Now go to product.json in the resources/app/ folder of your extracted appimage.
Inside change the setting “vscodeVersion” from 1.80.x to 1.82.x.
Doing so I was able to update all extensions to their pre-release version.

Just 1 caveat, python and pylance seem to be locked, but doing like I wrote you will able to install the vsix file of whatever version fits your need.

Hope it helps, because by far and large Cursor is the best ai assistant I tried (I subscribed to at least a dozen of them, so I think I know one thing or too on this topic)

In my view, for Cursor to be seen as a viable alternative that builds on VSCode the project needs to keep up to date with recent major releases of the VSCode project.

I understand that it’s not something the Cursor team want to continuously do so I think the minor releases could be missed but every major release should be integrated.

As I mentioned VSCode is currently v1.83 but Cursor is at v1.80, so 3 major releases behind VSCode. The bigger the version difference the harder it will be to maintain parity with VSCode and for most this will be a blocker.

To be clear: if Cursor were not to keep up to date with VSCode I would likely keep using it but only until a better alternative was available. It affects Extensions and security so please don’t overlook this Cursor team :pray:


Is there any estimate on when this would be available? Cursor has been rendered unusable for me as a result of this sadly.

We appreciate all the feedback here! Certainly moves this merge up our priority list.

Out of curiosity, what specific problem made Cursor unusable for you? Was it an incompatible extension, or something else?

The Ruby LSP extension is needed for formatting, go to definition etc. but it gives the error message above

“The language client requires VS Code version ^1.82.0 but received version 1.80.1”

1 Like

I just noticed this too! Same issue with the Ruby LSP extension.

Thank you for sending this. Really bad that the Ruby extension isn’t working at all. We will have a fix live by tomorrow night.

1 Like

Pls dont forget the whole vscode python ecosystem that is freezed to 4/6 months ago

1 Like

yep we are largely updating to the newest versionof vscode.


Can you let us know here when this has been done. Thank you! :pray:

Can you please hurry up? Now pylance(default language server for python) doesn’t work anymore. I must use pyright but is far from optimal. Vscode parity should be a priority being your product not free (and the most pricey in this type of plugin)

The update should drop today or tomorrow morning. The team is working really hard on it. Thank you for your patience!

Thank you for your update :smiling_face_with_three_hearts: