Cursor AI Chat Connection Failed

Request ID: f03e842a-2b5f-41f9-9df8-0b1dc0c4acbf

The problem of failed connection persists under my cursor account ( I have already checked my internet connection and VPN, but I haven’t found any problem with them. Could you please help me fix this issue as soon as possible since I need to use it right now. Thanks in advance!

1 Like

Does the issue still persist for you?

Yes, here is the new screenshot:

Are you able to access

Yes I am able to access it. It shows this message: Welcome to Cursor. From server kv1npcv8x8hq3qcdnoh0h with time 0.188659000210464. Pod name: local-machine. Pod IP:

Sorry for possible bombarding the messages. I know you guys must be very busy and I really love your great works. It is just frustrating for me that I have subscribed to pro but unable to use the AI chat for nearly a week, don’t understand why it’s not working.

Any update? I just tried the AI chat again but still got connection failed. Here is the new screenshot:

Few people reported connection issues with the @Web feature here: Web Search Function - Connection Failure

Are you using @Web in your prompts or have “Always search the web” enabled?


I just toggled “Always search the web” on and reloaded cursor. I can successfully @Web under the normal chat mode in the AI chat pane, but I am still getting this Connection Failed error when I tried to @ a specific file in my current project folder, as shown in the screenshots below:

As a reference it might help, I am able to @ a specific file or do a web search using Phind extension in cursor perfectly fine without any problem.

@truell20 @Jakob I just tried to test the AI chat again. The good news is that this time I am only getting Connection Failed error when I @ a specific file in the chat. When I @ folders/code/web/docs/lint errors/codebase, they all work perfectly without any issue. And I get empty response when @ git in the chat, as shown in the screenshot below (not sure if it is to be expected):

So I think the main problem lies in the @files and @git features, which may narrow down your debugging range.

1 Like

@truell20 @Jakob I think I have just finally figured out the issues in my case. The connection failed error I got when trying to @ a ipynb file in the chat is most probably related to the Jupyter server connection issues. After clearing all outputs and restarting the Jupyter kernel in the notebook, the connection failed error is gone and the generation works perfectly.

Anyway, thanks a lot for your ongoing support and assistance! Really appreciate your every effort on it.

I was having this error on every single request with @web, but might just be an intermittent issue on Cursor’s end, as it just started working for me and seemed to have nothing at all to do with any settings I had on or off.

One thing I’ll note is that requests to ReportBug seemed to fail in the developer tools, causing me to turn privacy mode on, and it worked after a couple tries. Could be coincidence though as it seems to be working either way now.

1 Like

@KenPan could you please share the steps for clearing all outputs and restarting the Jupyter kernel? I’m facing the same issue.

P.S. Somehow it got resolved by itself. Not sure if it was the same problem or some other connection issue.

I am currently experiencing this on a daily basis with no resolution, and it’s been happening on and off since I first started using Cursor a few months ago. On rare instances, I can get through about 4-5 prompts with no issues before it strikes again randomly. I finally took a screen recording just to show what it’s like, and it’s like this all the time: I had to click “try again” a total of 24 times just to get a complete response. It’s becoming almost to the point of non-usability. I don’t know what to do here. I’m a pro user, I’ve tried across all different models including cursor fast, I’m in the U.S., no VPN. I feel like I must certainly be exceeding a rate limit but it’s a catch-22 since I don’t know what else to do when the connection drops other than to keep trying again.

A much more stable fix will be rolled out tomorrow