How come I can't access GPT4?

I entered my Open AI key. Yet, all the dropdowns list only GPT3? I need to be using GPT4 but it is not available.

I have already tried a workaround provided by another forum, which was to toggle the Using Key option off and on. It did not help.

This is my last big question. Once I can use GPT-4 using my API key, and once the chat feature is able to answer questions about my whole code base instead of just the open file, I can make more progress experimenting with cursor and consider subscribing. But, since stuck with GPT-3 only, which does not know my project is indexed, this is worse than vs-code with Co-Pilot.

Could you make sure your API key works with GPT-4? If it doesn’t, then the model won’t show in the dropdown.

Why would it not work with GPT-4? I use GPT-4 every day.
Plan: Plus, $20 a month.

However, the web site at OpenAI Platform let’s me create new keys. It doesn’t say anything about what those keys that can be used for. They are just keys so that I can get billed for whatever model I use.

It doesn’t appear that there are different API keys for different models. They are just OpenAI API keys.

Don’t shoot the messenger here - again, I don’t work for Cursor or OpenAI, I’m just an end user like you. :slight_smile:

You might or might not already be aware of this, but just in case - “Plan: Plus, $20 a month” isn’t an OpenAI GPT API plan, that’s a ChatGPT plan. Confusingly, the two are totally separate (blame OpenAI not me or Cursor). Paying for an upgrade to the ChatGPT app gets you enhanced features for chatting with their chatbot, but it doesn’t come with any API credits or affect API access in any way.

I wasn’t sure if you’re saying you have another billing account specific to the API or not. If you haven’t funded an API account separate to ChatGPT, I think you should be able to create keys that can access the API on the free tier (YMMV), but subject to some pretty aggressive limits, possibly too aggressive for this use case. If you don’t have one, and you’re planning to get into using your own API keys, it’s probably worth spending some time reading the OpenAI docs and understanding their billing model.

(Obviously not an answer to the original question about models, but possibly helpful context for anyone reading the thread who might not know that ChatGPT and API are completely distinct.)

1 Like

Also possibly thread-relevant for anyone wondering if there’s a programmatic way to check if their key has access to gpt-4 (Python example):

>>> import openai
>>> openai.api_key = "<YOUR-KEY-HERE>"
>>> any('gpt-4') for x in openai.Model.list()['data'])
>>> any('gpt-5') for x in openai.Model.list()['data'])

Thank you. No, my key does not have access to GPT-4. Docs say that they have granted access to anyone has made a successful payment. However, they have never invoiced me and there seems no way to pay without a balance due. I put in a support request for this chicken and egg problem.

I had the same issue and what worked for me was cancelling my current billing plan and then creating a new plan that uses prepaid billing instead of pay-as-you-go which is what my previously plan was. After that I was able to test a few different ways that I now have access to GPT4 via the API.

Once that was sorted, I went to Cursor and togged off the “Using key” under the OpenAI API setting, and then quit Cursor completely and relaunched it. After it reopened I went in and toggled the API back on, closed out of that settings page, reloaded the Cursor UI (search ‘reload window’ via the command palette), after which I could now select gpt-4 in the chat. I was able to confirm by asking what gpt model it’s using and it responded with GPT-4.

Seems like OpenAI changed their billing type from pay-as-you-go to prepaid billing, but might have only been enforcing it for new accounts. But since they then added the “successful payment of $1 or more” constraint to be able to access the GPT-4 API, it was now blocking accounts that had previously been able to use GPT-4 API just fine and didn’t provide any messaging about what was going on.

Hope that works for you like it did for me

1 Like

Thank you. I did cancel my billing plan and pick a new one with pre-paid billing, and that did fix the problem. Those steps were perfect.

My remaining problem is that cannot answer questions about any code that is not currently selected, even though I press Ctrl+Edit and the More tab says the index is synced.

For example:
Tell me about <Ctrl+Enter> is not included in the provided code snippets, so I cannot provide specific information about its contents or functionality.

I thought the point of cursor was that it would be able to answer questions about the code base rather than just about selected code.