Enabling GPT-4 in Cursor using own key

Hello. :wave:

I have access to GTP-4 via the API.
See manual test below

However when using the same key in Cursor (all updates applied) I only see GPT-3.5 available.

(2-in-1 screenshot since I am restricted as a new forum member)

Why do I not see GPT-4?
Am I missing something really basic?

Thank you,

Hmmm. If you toggle the key on and off and hit enter in the key textbox, does the menu update with GPT-4?

Thank you for this.
I can confirm that with this little “dance” it gets updated.

@truell20 for me, once I put my key in, the option goes away. I’ll do the little dance, toggling it on and off, but if my API key is in the box, it won’t allow it to be 3.5. Is this a permissions issue with my API Key?

Maybe this is the reason why: How can I access GPT-4? | OpenAI Help Center

API Access

On July 6 , 2023, we gave access to the GPT-4 API (8k) to all API users who have made a successful payment of $1 or more. We plan to open up access to all developers soon, and then start raising rate-limits after that depending on compute availability.

We are not currently granting access to GPT-4-32K API, but it will be made available at a later date.

For API accounts created after August 18, 2023, you can get instant access to GPT-4 after purchasing $0.50 worth or more of pre-paid credits. You can read about prepaid billing here.

Turns out I had to cancel my Billing Subscription (which i’ve had for many months, but never had a bill) and renew. Once I renewed, it gave me the option to pre-purchase.

Once I did this, I was able to toggle the “using key” button off, then select GPT 4, and then paste in my API Key, and then toggle on “using key”. That worked.


Silly question: How do I get to this screen to set my own OpenAI key? I tried searching on the settings, but couldn’t find anything

Also, tried on the settings on the Cursor webpage, there I just see my current usage of OpenAI requests, and an option to upgrade my Cursor account

Try Ctrl / Cmd + Shift + P, then “Cursor settings”

Worked! Thanks

Is it still possible to use GPT-4 with my own API key? When I toggle “Using key” to “on,” I’m no longer able to select GPT-4 as the model in the chat window.

You should be able to! Are you sure you have API key access to GPT-4? Could you try making a request with the OAI API to test?

Thanks! I finally solved this by cancelling pay-as-you-go billing in my OpenAI account and replacing it with prepaid billing (as described here).