I cant't select a model in settings

i have provided my own Api Key with GPT-4 access. But I can’t select any model in the settings.
I also reinstalled the editor

1 Like

I just wondered the same thing, especially now that we have the new GPT4 Turbo model and I’d love to switch to that one.

Is there any way to set the model to be used?

Currently, using your own OpenAI key still only allows you to use (old) GPT-4 or GPT-3.5 Turbo.

With the new 0.15.0 update, you can now use the latest GPT-4 with your own API key.


1 Like

Is the GPT-4-1106-preview available to Pro subscribers yet? I only see GPT-3.5 and GPT-4 as options.

No. Only with your own OpenAI API key so far.

Btw, thats because the model is in preview mode and we are actively working on getting a quota that can support our pro users. The model is not in production support yet and doesnt give a high enough quota to anyone.


@Jakob i cant see where i can download this version. I use gpt key

@banity You can redownload from https://cursor.sh/. All of your settings, extensions, etc., will transfer to the redownloaded version. You don’t have to uninstall the existing version first.

thanks a lot ;D

1 Like

still no updated dropdown sadly, do you need to have pro version?

@banity No, you don’t need Pro. Open Cursor settings (Ctrl + Shift + J), scroll down to “OpenAI API”. Fill out the key input. Click on the Arrow Icon button on the right to verify your key. Make sure the switch is enabled. And then the new model should be available if your OpenAI account (API Account, not ChatGPT+) has access to the new GPT-4 model.



Hi! Quick question. If we use our own API key, what’s the context window? Do we get to use more of it at all, or is it still at 8000?

Works great! thanks

For anyone else reading this, I had to toggle Using key on and off. I redownloaded it too but I was already on the latest version.

@darink Cursor should adjust to the bigger context window.