How to fix? [The model gpt-3.5-turbo does not work with your current plan or api key]

1 Like

This error only ocurred in this condition:
GPT-3.5 and command-k.

In other conditions, it works fine…


Same for me

There’s something wrong on Cursor’s side. Sorry for the inconvenience!


Same here! I just updated to 0.14.0. I’m on the Cursor Pro subscription…

1 Like

I’ve just switched to the Cursor Nightly Build and it seems to have been fixed. See here for details… How to join Cursor Nightly

1 Like

It’s fixed now. Thank you for your report!

1 Like

Got it, thank you for your explaining.

The model [model name] does not work with your current plan or api key

It is not fixed. (using v0.18.2 currently)

Whenever I use @Codebase with Advanced settings and “Reasoning step” set to “yes”, it will always give me above error.

@RealityMoez That might be because when you have GPT-4 selected, the “Reasoning step” will use GPT-4-32k, which you might not have access to.

1 Like

You should improve the error message though.
Because it doesn’t mention that. (the GPT-4-32k)

I still get this error message. Note that it doesn’t really make sense to use GPT-4-32K anymore given that GPT-preview has >100k context and is faster.

This ticket is listed as solved but it really isn’t on the current release.