[SOLVED] Persistent "Connection Failed" Error in Cursor IDE Side Chat

I am writing to report a recurring issue I have been encountering with the Cursor IDE side chat feature. Despite multiple attempts to resolve the problem, including clearing the cache and reinstalling the IDE, the “Connection failed, try again.” error persists frequently. This issue occurs irrespective of using a Virtual Private Network (VPN); I have experimented with connections from various countries to no avail.

Furthermore, I have previously submitted numerous feedback reports to hi@cursor.sh, yet I have received minimal communication in return. My workstation is connected via an Ethernet connection, boasting download and upload speeds of approximately 700 Mbps and 50 Mbps, respectively.

This problem has been ongoing for nearly a month since I commenced usage of Cursor IDE, under a paid subscription. Both fast and slow requests invariably result in the aforementioned “Connection failed” error at a high frequency.

It significantly hampers my productivity and user experience.

I am using the latest paid Cursor version with the GPT-4 model.

More details as I see them in network logs from Cursor.

The error happens on the POST request to


An error there just says: “peer closed connection”

But further, I see the request to


And there is more info:

"bug": "automatic-from-connection-error.\n\nrequest ID:bc51fc1c-9c56-464e-9aee-a03c84cff28e\n\nerror:undefined\n\nerror:{\"name\":\"ConnectError\",\"rawMessage\":\"Failed to fetch\",\"code\":2,\"metadata\":{},\"details\":[]}",
    "bugType": "BUG_TYPE_MEDIUM",
    "contactEmail": "automatic-from-connection-error",
    "context": {
        "connectionErrorRaw": "Failed to fetch",

Also, there are consoleLogs with mostly warnings, but also with an error related to the attempt to fetch data but failing. But no real useful details.

@truell20 and @npour please let me know if I can share more details with you. The issue is still there.


One new observation is that, if I remove all the extensions, it fails at a much lower rate. I run the “rm -rf .cursor/extensions/”, coz removing all the extensions just on the IDE is not enough.

Or as an alternative - “cursor --disable-extensions”, also helps.

I still did not get any responses to my request for support I set it to hi@cursor.sh.

Same here. Tried to disable extensions, but it didn’t help, but thanks for ideas @up.wader_0v

Found solution. I was using google drive app on my mac m1 and probably have some files indexed by cursor that was on google drive (didn’t spend time investigating), and only when i turned off the app I receive no Connection errors anymore. Tried to turn it on again, and received Connection error again. So for me is google drive app

after a while the error reappeared again, so sorry, not a solution

Yes, I also tried many things including the DNS changes, etc. Surprisingly it only errors the for the GPT-4. The GPT-3.5 model works just fine.

Unfortunately, the Cursor team is not super responsive and some of the feedback I sent is approx. 1 month old.

sorry, we have been incrementally tracking down connection errors. some of them are harder to track down than other :frowning: :frowning: because folks are on privacy mode so we dont see a lot of logs. I will continue working on them to improve the experience for all of you.

the persistence is very suprising and hints to me that there is a client bug that we are not seeing. would any of you be down to hop on a call with me? (sualeh@anysphere.co)

1 Like

I emailed you.

Maybe this will help:
request id’s in sequence. Note: using slow ones responses. Errors occurred in narrow time window

  1. Using my oai api GPT-4
    dc5a09fe-73bc-4591-ab5f-e9fc34508159 //my oai api
    3131f695-7d7e-4f4e-be3a-70cc0cd1bf8a //my oai api
  2. switched to Cursor oai api GPT-4
  3. switched back to my oai api
    1c5b7fb8-83ea-4226-946f-60f33d16b989 //my oai api GPT-4
    fbf222b1-b0b3-4645-979e-a7f1a6fbc3e6 //my oai api GPT-4-0125-preview
    00db516e-3083-4b6e-a717-7dfaf84bc510 //my oai api GPT-3.5-turbo-1106
  4. My api, but switched to mobile internet
    5abf2d58-9dab-43d5-ba10-0666d9eb3c2d //after ~10-15 requests
    Api key not related. Internet - seems not related. Checked - OAI operational status = OK.
    Extensions disabled

Just for a history - we had a call with @sualeh and I provided all the information possible to debug this issue.

@sualeh I keep having this issue almost everytime now, especially during high traffic mornings like today. It happens even when i use my own key.

Good to see that this issue moved to the “in-progress” status!

After the call with @sualeh I did not hear anything yet.

I can report that as of Cursor 0.32.0+, which I used for a few days, I have seen none of the “Connection Failed” errors in Side Chat.

Amazing! we will publically release the special version of 0.32 soon!

1 Like

@sualeh I wanted to highlight that I have seen the error again and quite often since Today. Not sure what has changed.

More context if this helps.

Do you still see issues in the newest version of Cursor? We changed how we were doing requests to make them much more resilient to blips.

Hi, @truell20! It seems that I rushed a little to report the previous issue.

After updating to the 0.33.1 for Apple Silicon I have not seen such network issues in the Chat.


1 Like