Cursor v0.28.1 is completely unusable due to lag


I updated to the latest version on my M2 Mac Pro and Cursor has suddenly become extremely laggy. Even quitting takes forever and typing is almost not possible. Every keystroke takes couple seconds.

I also tried re-installing but no luck.

Hi! Sorry about this — definitely want to fix it for you. Two questions:

  1. Did earlier versions of Cursor work for you, without this problem?
  2. Could you zip up and send over the /Users/arvid/Library/Application\ Support/Cursor/logs folder to Would be super helpful.

Other things to try:

  1. Does disabling Copilot++ (lower right corner) make a difference for you?
  2. Does the problem persist when doing an extension bisect?

I’m also having similar problems. Trying to use a jupyter nb is almost impossible due to the lag. I’m on the most up to date version of cursor (as of this morning). I tried deactivating all extensions and still having trouble.

Ok. I just ran Bisect and it seems Github Copilot is the one causing issues. And yes, this used to work previously and it started to have issues once I enabled Copilot++. But even if I disable Copilot++ it doesn’t help.

I have sent the logs through email.

Thanks for the help

I had the same issue. 0.28.1 cpu utilization is a runaway train even with no project open. I changed to using the nightly build which is 0.28.3 and the issue is gone.

Edit: i think i may have had copilot disabled however so ymmv

It seems likes Re-installing the Github Copilot extension fixes it.


Indeed re-installing github copilot seems to work. A few observations though.

When searching “Github Copilot” in the marketplace in Cursor it doesn’t show up in the search results??? Is this Cursor trying to make their own Copilot++ the ‘goto’ utility?

Also when download the .vsix manually off Microsoft Store, in Cursor there is no 3 dots to select “install from .vsix”. The Cursor instructions says to drag and drop into the marketplace view; but this isn’t possible if your’re using a tiling manager in Linux, such as i3 instead of a full-fledged desktop window manager.

I ended up install github copilot again in my OG VSCode and then moving the folder in .vscode/extensions into .cursor/extensions, and copying over the relative portion of .vscode/extensions/extensions.json to .cursor/extensions/extensions.json. A little bit painful.

1 Like